aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-26 14:57:50 +0200
committerRosen Penev <rosenp@gmail.com>2024-02-26 12:06:11 -0800
commit0a7794c57ecba1632ccbbbca1710774bee69f445 (patch)
tree3e574a27fef9f3078606a686614751380c1173d6
parentfa54dbc72a8aa25830b1c2e341876182ea19b455 (diff)
dump1090: fix soft float ARM build
Package CPU features detection is not supporting soft float ARM. So we disable it altogether. Signed-off-by: krant <aleksey.vasilenko@gmail.com>
-rw-r--r--utils/dump1090/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/utils/dump1090/Makefile b/utils/dump1090/Makefile
index bcaaef0d5..f3c85afd5 100644
--- a/utils/dump1090/Makefile
+++ b/utils/dump1090/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dump1090
PKG_VERSION:=9.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/flightaware/dump1090/tar.gz/v${PKG_VERSION}?
@@ -58,6 +58,10 @@ MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS)" \
UNAME="Linux"
+ifeq ($(CONFIG_SOFT_FLOAT),y)
+MAKE_FLAGS += CPUFEATURES=no
+endif
+
TARGET_LDFLAGS += -Wl,--as-needed
define Package/dump1090/conffiles