aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2021-06-27 16:26:39 -0600
committerPhilip Prindeville <philipp@redfish-solutions.com>2021-06-27 16:31:31 -0600
commit09dcf7486dc8cdf65cb46499d606d418848b6d93 (patch)
tree599c5156ee9a41040deea7253ffee789e35d470d
parent0ef9d54c6c598be62dce298f0590cb06e34064de (diff)
strongswan: rename config functions
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
-rw-r--r--net/strongswan/Makefile2
-rw-r--r--net/strongswan/files/swanctl.init10
2 files changed, 6 insertions, 6 deletions
diff --git a/net/strongswan/Makefile b/net/strongswan/Makefile
index 596bd8e38..a1eb7b8af 100644
--- a/net/strongswan/Makefile
+++ b/net/strongswan/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=strongswan
PKG_VERSION:=5.9.2
-PKG_RELEASE:=11
+PKG_RELEASE:=12
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
diff --git a/net/strongswan/files/swanctl.init b/net/strongswan/files/swanctl.init
index 884fefe38..6ccddb076 100644
--- a/net/strongswan/files/swanctl.init
+++ b/net/strongswan/files/swanctl.init
@@ -210,7 +210,7 @@ parse_ike_proposal() {
export -n "$var=$crypto"
}
-config_conn() {
+config_child() {
# Generic ipsec conn section shared by tunnel and transport
local config_name="$1"
local mode="$2"
@@ -322,14 +322,14 @@ config_conn() {
}
config_tunnel() {
- config_conn "$1" "tunnel"
+ config_child "$1" "tunnel"
}
config_transport() {
- config_conn "$1" "transport"
+ config_child "$1" "transport"
}
-config_remote() {
+config_connection() {
local config_name="$1"
local enabled
@@ -574,7 +574,7 @@ prepare_env() {
config_load ipsec
config_foreach config_ipsec ipsec
- config_foreach config_remote remote
+ config_foreach config_connection remote
do_postamble
}