aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2022-09-14 18:32:47 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2022-09-15 09:53:08 -0300
commit085eb34fbf7c7aaa20da35ebe2f493601c5f19b2 (patch)
tree2ae810b51d469a94b6c591f71ebea5d8a4494582
parent40f02355993a24dedcce87ef8487e0bbc8f5b402 (diff)
libgd: avoid recursive and redundant dependencies
Change the CONFLICTS line from the libgd-full to libgd to fix a recursive dependency. While at it, remove the redundant +LIBGD_TIFF:libtiff +LIBGD_FREETYPE:libfreetype dependencies from Package/libgd/default. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
-rw-r--r--libs/libgd/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/libs/libgd/Makefile b/libs/libgd/Makefile
index 83a61ca6b..4ca2eff2b 100644
--- a/libs/libgd/Makefile
+++ b/libs/libgd/Makefile
@@ -26,7 +26,7 @@ include $(INCLUDE_DIR)/cmake.mk
define Package/libgd/default
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=+libjpeg +libpng +libwebp +LIBGD_TIFF:libtiff +LIBGD_FREETYPE:libfreetype
+ DEPENDS:=+libjpeg +libpng +libwebp
TITLE:=The GD graphics library
URL:=https://libgd.github.io/
endef
@@ -36,6 +36,7 @@ define Package/libgd
MENU:=1
DEPENDS+=+LIBGD_TIFF:libtiff +LIBGD_FREETYPE:libfreetype
VARIANT:=default
+ CONFLICTS:=libgd-full
endef
define Package/libgd-full
@@ -44,7 +45,6 @@ define Package/libgd-full
TITLE+=(full)
VARIANT:=full
PROVIDES:=libgd
- CONFLICTS:=libgd
endef
define Package/libgd/description/default