aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-03-05 18:14:38 -0800
committerRosen Penev <rosenp@gmail.com>2021-03-07 14:49:05 -0800
commit07d0ee7552982cc36b52d0ec0af2f0526ffc6b43 (patch)
tree369e62eddf0e78d51af4e68718486c9d0e752834
parent6331dc62d58da2e9152d8623c55a10c3397eec72 (diff)
libmraa: fix compilation with GCC10
Taken from an upstream issue. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/libmraa/Makefile2
-rw-r--r--libs/libmraa/patches/030-gcc10.patch13
2 files changed, 14 insertions, 1 deletions
diff --git a/libs/libmraa/Makefile b/libs/libmraa/Makefile
index d05453e12..8c29d8dfe 100644
--- a/libs/libmraa/Makefile
+++ b/libs/libmraa/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libmraa
PKG_VERSION:=2.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/eclipse/mraa/tar.gz/v$(PKG_VERSION)?
diff --git a/libs/libmraa/patches/030-gcc10.patch b/libs/libmraa/patches/030-gcc10.patch
new file mode 100644
index 000000000..dad1249c8
--- /dev/null
+++ b/libs/libmraa/patches/030-gcc10.patch
@@ -0,0 +1,13 @@
+--- a/include/version.h
++++ b/include/version.h
+@@ -11,8 +11,8 @@
+ extern "C" {
+ #endif
+
+-const char* gVERSION;
+-const char* gVERSION_SHORT;
++extern const char* gVERSION;
++extern const char* gVERSION_SHORT;
+
+ #ifdef __cplusplus
+ }