aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Fleurant <meshnet@protonmail.com>2019-08-15 15:39:26 -0400
committerWilliam Fleurant <meshnet@protonmail.com>2019-08-16 00:22:11 -0400
commit07625bb6a7daf5af49a0a303ff42d426ebe43319 (patch)
tree564fe3696251cafe724097a6822a4d66cbda9f45
parent3a80fa9cb8a5f700b504921679e6d7485a8467f0 (diff)
yggdrasil: fix #9712 upstream dependency with branch develop
Signed-off-by: William Fleurant <meshnet@protonmail.com>
-rw-r--r--net/yggdrasil/Makefile2
-rw-r--r--net/yggdrasil/patches/001-aqua-de-coco.patch27
2 files changed, 28 insertions, 1 deletions
diff --git a/net/yggdrasil/Makefile b/net/yggdrasil/Makefile
index dfa0459df..27c218f44 100644
--- a/net/yggdrasil/Makefile
+++ b/net/yggdrasil/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=yggdrasil
PKG_VERSION:=0.3.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/yggdrasil-network/yggdrasil-go/tar.gz/v$(PKG_VERSION)?
diff --git a/net/yggdrasil/patches/001-aqua-de-coco.patch b/net/yggdrasil/patches/001-aqua-de-coco.patch
new file mode 100644
index 000000000..896cb6172
--- /dev/null
+++ b/net/yggdrasil/patches/001-aqua-de-coco.patch
@@ -0,0 +1,27 @@
+diff --git a/go.mod b/go.mod
+index 84025df..7b82066 100644
+--- a/go.mod
++++ b/go.mod
+@@ -8,7 +8,7 @@ require (
+ github.com/kardianos/minwinsvc v0.0.0-20151122163309-cad6b2b879b0
+ github.com/mitchellh/mapstructure v1.1.2
+ github.com/songgao/packets v0.0.0-20160404182456-549a10cd4091
+- github.com/yggdrasil-network/water v0.0.0-20190725123504-a16161896c34
++ github.com/yggdrasil-network/water v0.0.0-20190812103929-c83fe40250f8
+ golang.org/x/crypto v0.0.0-20190701094942-4def268fd1a4
+ golang.org/x/net v0.0.0-20190724013045-ca1201d0de80
+ golang.org/x/sys v0.0.0-20190801041406-cbf593c0f2f3
+diff --git a/go.sum b/go.sum
+index 81d337e..0c35f1c 100644
+--- a/go.sum
++++ b/go.sum
+@@ -22,6 +22,8 @@ github.com/yggdrasil-network/water v0.0.0-20190725073841-250edb919f8a h1:mQ0mPD+
+ github.com/yggdrasil-network/water v0.0.0-20190725073841-250edb919f8a/go.mod h1:R0SBCsugm+Sf1katgTb2t7GXMm+nRIv43tM4VDZbaOs=
+ github.com/yggdrasil-network/water v0.0.0-20190725123504-a16161896c34 h1:Qh5FE+Q5iGqpmR/FPMYHuoZLN921au/nxAlmKe+Hdbo=
+ github.com/yggdrasil-network/water v0.0.0-20190725123504-a16161896c34/go.mod h1:R0SBCsugm+Sf1katgTb2t7GXMm+nRIv43tM4VDZbaOs=
++github.com/yggdrasil-network/water v0.0.0-20190812103929-c83fe40250f8 h1:YY9Pg2BEp0jeUVU60svTOaDr+fs1ySC9RbdC1Qc6wOw=
++github.com/yggdrasil-network/water v0.0.0-20190812103929-c83fe40250f8/go.mod h1:R0SBCsugm+Sf1katgTb2t7GXMm+nRIv43tM4VDZbaOs=
+ golang.org/x/crypto v0.0.0-20181203042331-505ab145d0a9 h1:mKdxBk7AujPs8kU4m80U72y/zjbZ3UcXC7dClwKbUI0=
+ golang.org/x/crypto v0.0.0-20181203042331-505ab145d0a9/go.mod h1:6SG95UA2DQfeDnfUPMdvaQW0Q7yPrPDi9nlGo2tz2b4=
+ golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2/go.mod h1:djNgcEr1/C05ACkg1iLfiJU5Ep61QUkGW8qpdssI0+w=
+