aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-11-19 14:07:05 -0800
committerRosen Penev <rosenp@gmail.com>2018-11-19 14:07:23 -0800
commit05d11f13c387e5736e9ca04715fe31c89fe2172c (patch)
tree81f0e8efc1428aa210eaba6033c46aac346111d8
parentecd3dc4d7fa73ac015388832af0c3d7b5c939bd5 (diff)
poco: Update to 1.9.0
Some minor adjustments. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/poco/Makefile9
-rw-r--r--libs/poco/patches/100-configure.patch14
-rw-r--r--libs/poco/patches/200-strerror.patch4
3 files changed, 14 insertions, 13 deletions
diff --git a/libs/poco/Makefile b/libs/poco/Makefile
index 54041a449..b74845a3c 100644
--- a/libs/poco/Makefile
+++ b/libs/poco/Makefile
@@ -9,16 +9,17 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=poco
-PKG_VERSION:=1.8.1
+PKG_VERSION:=1.9.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://pocoproject.org/releases/$(PKG_NAME)-$(PKG_VERSION)
-PKG_HASH:=2e4c07ac73174ee06c7e2c7cf2b7642a5b3aea81d0203e1c069b32ac4a8ecfbc
+PKG_SOURCE_URL:=https://pocoproject.org/releases/$(PKG_NAME)-$(PKG_VERSION)
+PKG_HASH:=a0a5a03d87c585f1a43def33bfc52c0c34a528e43a7b13bc83841a7c00adde39
PKG_LICENSE:=BSL-1.0
PKG_LICENSE_FILES:=LICENSE
+PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
@@ -27,7 +28,7 @@ define Package/poco
SECTION:=libs
CATEGORY:=Libraries
TITLE:=Poco C++ libraries
- URL:=http://www.pocoproject.org/
+ URL:=https://www.pocoproject.org/
DEPENDS:=+libstdcpp +libpthread +librt
MAINTAINER:=Jean-Michel Julien <jean-michel.julien@trilliantinc.com>
endef
diff --git a/libs/poco/patches/100-configure.patch b/libs/poco/patches/100-configure.patch
index 1051dfc7a..01ceb6767 100644
--- a/libs/poco/patches/100-configure.patch
+++ b/libs/poco/patches/100-configure.patch
@@ -1,15 +1,15 @@
--- a/configure
+++ b/configure
-@@ -231,9 +231,9 @@
- ;;
-
- *)
+@@ -237,9 +237,9 @@ while [ $# -ge 1 ]; do
+ ;;
+
+ *)
- showhelp
- exit 1
- ;;
+# showhelp
+# exit 1
+# ;;
- esac
-
- shift
+ esac
+
+ shift
diff --git a/libs/poco/patches/200-strerror.patch b/libs/poco/patches/200-strerror.patch
index bd6075497..0ff0ce5ed 100644
--- a/libs/poco/patches/200-strerror.patch
+++ b/libs/poco/patches/200-strerror.patch
@@ -1,8 +1,8 @@
--- a/Foundation/src/Error.cpp
+++ b/Foundation/src/Error.cpp
@@ -70,7 +70,7 @@ namespace Poco {
-
- #if (_XOPEN_SOURCE >= 600) || POCO_ANDROID || __APPLE__
+
+ #if (_XOPEN_SOURCE >= 600) || POCO_OS == POCO_OS_ANDROID || __APPLE__
setMessage(strerror_r(err, _buffer, sizeof(_buffer)));
-#elif _GNU_SOURCE
+#elif (_GNU_SOURCE && (defined __GLIBC__ || defined __UCLIBC__))