aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-28 02:03:10 -0700
committerGitHub <noreply@github.com>2020-04-28 02:03:10 -0700
commit051f998a140698296db744da2f17d9c432e82c35 (patch)
tree08a504904c1bbdf2a6cbc3857b325f7e0febaa8d
parent8e00acd533382c5b2adf46a484c7b8b084d3a24e (diff)
parent63ff065d82d4ac9d22f9daa16e1e3d13642b6c92 (diff)
Merge pull request #11937 from neheb/coreu
coreutils: update to 8.32
-rw-r--r--utils/coreutils/Makefile44
-rw-r--r--utils/coreutils/patches/001-no_docs_man_tests.patch20
-rw-r--r--utils/coreutils/patches/002-strtod-fix-clash-with-strtold.patch41
3 files changed, 39 insertions, 66 deletions
diff --git a/utils/coreutils/Makefile b/utils/coreutils/Makefile
index 58612e3d2..cfe1113c6 100644
--- a/utils/coreutils/Makefile
+++ b/utils/coreutils/Makefile
@@ -8,13 +8,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=coreutils
-PKG_VERSION:=8.31
+PKG_VERSION:=8.32
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/coreutils
-PKG_HASH:=ff7a9c918edce6b4f4b2725e3f9b37b0c4d193531cac49a48b56c4d0d3a9e9fd
+PKG_HASH:=4458d8de7849df44ccab15e16b1548b285224dbba5f08fac070c1c0e0bcc4cfa
+
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_LICENSE_FILES:=COPYING
PKG_CPE_ID:=cpe:/a:gnu:coreutils
PKG_BUILD_PARALLEL:=1
@@ -22,18 +25,18 @@ PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
COREUTILS_APPLETS := \
- base64 basename cat chcon chgrp chmod chown chroot cksum comm cp csplit \
- cut date dd dir dircolors dirname du echo env expand expr factor \
- false fmt fold groups head hostid id install join kill link ln logname \
- ls md5sum mkdir mkfifo mknod mktemp mv nice nl nohup nproc od paste \
- pathchk pinky pr printenv printf ptx pwd readlink realpath rm rmdir \
- runcon seq sha1sum sha224sum sha256sum sha384sum sha512sum shred \
- shuf sleep sort split stat stdbuf stty sum sync tac tail tee test \
- timeout touch tr true truncate tsort tty uname unexpand uniq unlink \
- uptime users vdir wc who whoami yes
+ base32 base64 basename basenc b2sum cat chcon chgrp chmod chown chroot \
+ cksum comm cp csplit cut date dd df dir dircolors dirname du echo env \
+ expand expr factor false fmt fold groups head hostid id install join \
+ kill link ln logname ls md5sum mkdir mkfifo mknod mktemp mv nice nl \
+ nohup nproc numfmt od paste pathchk pinky pr printenv printf ptx pwd \
+ readlink realpath rm rmdir runcon seq sha1sum sha224sum sha256sum \
+ sha384sum sha512sum shred shuf sleep sort split stat stdbuf stty sum \
+ sync tac tail tee test timeout touch tr true truncate tsort tty uname \
+ unexpand uniq unlink uptime users vdir wc who whoami yes
DIR_BIN := \
- base64 cat chgrp chmod chown cp date dd echo false kill link ln ls \
+ base64 cat chgrp chmod chown cp date dd df echo false kill link ln ls \
mkdir mknod mktemp mv nice printenv pwd rm rmdir sleep stat stty sync \
touch true uname
@@ -49,8 +52,8 @@ DIR_USR_SBIN := \
# BusyBox does not provide these yet
DIR_OTHERS := \
- chcon csplit dir dircolors fmt join pathchk pinky pr ptx runcon \
- sha224sum sha384sum stdbuf tsort vdir
+ base32 b2sum basenc chcon csplit dir dircolors fmt join numfmt pathchk \
+ pinky pr ptx runcon sha224sum sha384sum stdbuf tsort vdir
$(eval $(foreach a,$(DIR_BIN),ALTS_$(a):=300:/bin/$(a):/usr/bin/gnu-$(a)$(newline)))
$(eval $(foreach a,$(DIR_USR_BIN),ALTS_$(a):=300:/usr/bin/$(a):/usr/bin/gnu-$(a)$(newline)))
@@ -115,7 +118,18 @@ endif
CONFIGURE_ARGS += \
--disable-xattr \
- --enable-install-program=su
+ --enable-install-program=su \
+ --enable-threads=posix \
+ --enable-acl \
+ --disable-assert \
+ --disable-rpath \
+ --disable-libsmack \
+ --enable-libcap \
+ --without-linux-crypto \
+ --without-openssl \
+ --$(if $(CONFIG_USE_MUSL),with,without)-included-regex \
+ --without-selinux \
+ --with-gmp
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
diff --git a/utils/coreutils/patches/001-no_docs_man_tests.patch b/utils/coreutils/patches/001-no_docs_man_tests.patch
index 9a6fe31b0..0d8dd0d75 100644
--- a/utils/coreutils/patches/001-no_docs_man_tests.patch
+++ b/utils/coreutils/patches/001-no_docs_man_tests.patch
@@ -9,7 +9,7 @@
EXTRA_DIST = \
.mailmap \
-@@ -210,6 +210,3 @@ AM_CPPFLAGS = -Ilib -I$(top_srcdir)/lib
+@@ -210,6 +210,3 @@ AM_CPPFLAGS = -Ilib -I$(top_srcdir)/lib -Isrc -I$(top_srcdir)/src
include $(top_srcdir)/lib/local.mk
include $(top_srcdir)/src/local.mk
@@ -18,7 +18,7 @@
-include $(top_srcdir)/tests/local.mk
--- a/Makefile.in
+++ b/Makefile.in
-@@ -2651,11 +2651,7 @@ RECURSIVE_TARGETS = all-recursive check-
+@@ -3156,11 +3156,7 @@ RECURSIVE_TARGETS = all-recursive check-recursive cscopelist-recursive \
install-ps-recursive install-recursive installcheck-recursive \
installdirs-recursive pdf-recursive ps-recursive \
tags-recursive uninstall-recursive
@@ -31,7 +31,7 @@
am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
am__vpath_adj = case $$p in \
$(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
-@@ -2905,11 +2901,11 @@ am__DIST_COMMON = $(doc_coreutils_TEXINF
+@@ -3411,11 +3407,11 @@ am__DIST_COMMON = $(doc_coreutils_TEXINFOS) $(srcdir)/Makefile.in \
$(top_srcdir)/build-aux/missing \
$(top_srcdir)/build-aux/test-driver \
$(top_srcdir)/build-aux/texinfo.tex \
@@ -46,7 +46,7 @@
ChangeLog INSTALL NEWS README THANKS TODO build-aux/ar-lib \
build-aux/compile build-aux/config.guess \
build-aux/config.rpath build-aux/config.sub build-aux/depcomp \
-@@ -3009,7 +3005,7 @@ EOVERFLOW_HIDDEN = @EOVERFLOW_HIDDEN@
+@@ -3516,7 +3512,7 @@ EOVERFLOW_HIDDEN = @EOVERFLOW_HIDDEN@
EOVERFLOW_VALUE = @EOVERFLOW_VALUE@
ERRNO_H = @ERRNO_H@
EXEEXT = @EXEEXT@
@@ -55,7 +55,7 @@
FLOAT_H = @FLOAT_H@
FNMATCH_H = @FNMATCH_H@
GETADDRINFO_LIB = @GETADDRINFO_LIB@
-@@ -4316,7 +4312,7 @@ libexecdir = @libexecdir@
+@@ -4961,7 +4957,7 @@ libexecdir = @libexecdir@
lispdir = @lispdir@
localedir = @localedir@
localstatedir = @localstatedir@
@@ -64,7 +64,7 @@
mandir = @mandir@
mkdir_p = @mkdir_p@
oldincludedir = @oldincludedir@
-@@ -4339,7 +4335,7 @@ top_build_prefix = @top_build_prefix@
+@@ -4984,7 +4980,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
ALL_RECURSIVE_TARGETS = distcheck-hook check-root
@@ -73,7 +73,7 @@
#if GNU_MAKE
# [nicer features that work only with GNU Make]
-@@ -6354,7 +6350,7 @@ all: $(BUILT_SOURCES)
+@@ -7030,7 +7026,7 @@ all: $(BUILT_SOURCES)
.SUFFIXES: .1 .c .dvi .log .o .obj .pl .pl$(EXEEXT) .ps .sh .sh$(EXEEXT) .trs .x .xpl .xpl$(EXEEXT) .y
am--refresh: Makefile
@:
@@ -82,9 +82,9 @@
@for dep in $?; do \
case '$(am__configure_deps)' in \
*$$dep*) \
-@@ -6376,7 +6372,7 @@ Makefile: $(srcdir)/Makefile.in $(top_bu
- echo ' cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__depfiles_maybe)'; \
- cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__depfiles_maybe);; \
+@@ -7052,7 +7048,7 @@ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ echo ' cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__maybe_remake_depfiles)'; \
+ cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__maybe_remake_depfiles);; \
esac;
-$(top_srcdir)/lib/local.mk $(srcdir)/lib/gnulib.mk $(top_srcdir)/src/local.mk $(srcdir)/src/cu-progs.mk $(top_srcdir)/src/single-binary.mk $(top_srcdir)/doc/local.mk $(top_srcdir)/man/local.mk $(top_srcdir)/tests/local.mk $(am__empty):
+$(top_srcdir)/lib/local.mk $(srcdir)/lib/gnulib.mk $(top_srcdir)/src/local.mk $(srcdir)/src/cu-progs.mk $(top_srcdir)/src/single-binary.mk $(am__empty):
diff --git a/utils/coreutils/patches/002-strtod-fix-clash-with-strtold.patch b/utils/coreutils/patches/002-strtod-fix-clash-with-strtold.patch
deleted file mode 100644
index f948f7922..000000000
--- a/utils/coreutils/patches/002-strtod-fix-clash-with-strtold.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 0562b040fa17f1722ba2b3096067b45d0582ca53 Mon Sep 17 00:00:00 2001
-From: Paul Eggert <address@hidden>
-Date: Mon, 11 Mar 2019 16:40:29 -0700
-Subject: [PATCH] strtod: fix clash with strtold
-
-Problem reported for RHEL 5 by Jesse Caldwell (Bug#34817).
-* lib/strtod.c (compute_minus_zero, minus_zero):
-Simplify by remving the macro / external variable,
-and having just a function. User changed. This avoids
-the need for an external variable that might clash.
---- a/lib/strtod.c
-+++ b/lib/strtod.c
-@@ -294,16 +294,15 @@ parse_number (const char *nptr,
- ICC 10.0 has a bug when optimizing the expression -zero.
- The expression -MIN * MIN does not work when cross-compiling
- to PowerPC on Mac OS X 10.5. */
--#if defined __hpux || defined __sgi || defined __ICC
- static DOUBLE
--compute_minus_zero (void)
-+minus_zero (void)
- {
-+#if defined __hpux || defined __sgi || defined __ICC
- return -MIN * MIN;
--}
--# define minus_zero compute_minus_zero ()
- #else
--DOUBLE minus_zero = -0.0;
-+ return -0.0;
- #endif
-+}
-
- /* Convert NPTR to a DOUBLE. If ENDPTR is not NULL, a pointer to the
- character after the last one used in the number is put in *ENDPTR. */
-@@ -479,6 +478,6 @@ STRTOD (const char *nptr, char **endptr)
- /* Special case -0.0, since at least ICC miscompiles negation. We
- can't use copysign(), as that drags in -lm on some platforms. */
- if (!num && negative)
-- return minus_zero;
-+ return minus_zero ();
- return negative ? -num : num;
- }