aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortripolar <tripolar@users.noreply.github.com>2015-12-13 23:44:57 +0100
committertripolar <tripolar@users.noreply.github.com>2015-12-13 23:44:57 +0100
commit0444536ea6568e3c1ddde0cc4b6cad2a410daeca (patch)
treeb86e28becba3a9d025d54e01bbc6c38e4018cbbe
parent9bd34cd554b624915ec9e7b61909ded75de703ae (diff)
parent2238ccc7c2285dc00357f78ec2a7c6aac36a16b1 (diff)
Merge pull request #2124 from commodo/ntpd-build-fix
ntpd: add libcap to default dependencies of the ntpd package
-rw-r--r--net/ntpd/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/net/ntpd/Makefile b/net/ntpd/Makefile
index feff2b458..0e446f9dd 100644
--- a/net/ntpd/Makefile
+++ b/net/ntpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ntp
PKG_VERSION:=4.2.8p4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/
@@ -31,7 +31,7 @@ define Package/ntpd/Default
TITLE:=ISC ntp
MAINTAINER:=Peter Wagner <tripolar@gmx.at>
URL:=http://www.ntp.org/
- DEPENDS:=+libopenssl +libpthread
+ DEPENDS:=+libopenssl +libpthread +libcap
endef
define Package/ntpd/Default/description
@@ -43,7 +43,6 @@ endef
define Package/ntpd
$(call Package/ntpd/Default)
TITLE+= server
- DEPENDS+= +libcap
USERID:=ntp=123:ntp=123
endef
@@ -67,7 +66,6 @@ endef
define Package/ntp-utils
$(call Package/ntpd/Default)
TITLE+= utilities
- DEPENDS+= +libcap
endef
define Package/ntp-utils/description
@@ -79,7 +77,7 @@ endef
define Package/ntp-keygen
$(call Package/ntpd/Default)
TITLE+=keygen
- DEPENDS+= +libcap +libevent2-core
+ DEPENDS+= +libevent2-core
endef
define Package/ntp-keygen/description