aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2022-12-19 08:13:08 +0100
committerFlorian Eckert <fe@dev.tdt.de>2022-12-19 08:34:54 +0100
commit0434407428b25ae5309525f060964218034b86c5 (patch)
tree0db94a899ab8e816f0ba542afd15f084e7fc46b4
parent3fd37a234c61146f6f6e921f7e3c7adfb19f4623 (diff)
mwan3: make mwan3.user executable
This is a fix for the the following change: https://github.com/openwrt/packages/commit/3d824ea288d907a31729c3629e884ea122c30da0 Before the change, it was only possible to execute a shell script. To remove this restriction, a binary or other script language can now also be used for 'mwan3.user'. Unfortunately, the old shell script was not executable for older mwan3 version. During a sysupgrade with config transfer, this 'mwan3.user' script could not be executed for newer mwan3 versions. To fix this, the calling script checks whether the 'mwan3.user' is executable, and if not, this executable bit is now set. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
-rw-r--r--net/mwan3/Makefile4
-rw-r--r--net/mwan3/files/etc/hotplug.d/iface/16-mwan3-user1
2 files changed, 3 insertions, 2 deletions
diff --git a/net/mwan3/Makefile b/net/mwan3/Makefile
index 878c4b993..a72289fc6 100644
--- a/net/mwan3/Makefile
+++ b/net/mwan3/Makefile
@@ -8,8 +8,8 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mwan3
-PKG_VERSION:=2.11.3
-PKG_RELEASE:=3
+PKG_VERSION:=2.11.4
+PKG_RELEASE:=1
PKG_MAINTAINER:=Florian Eckert <fe@dev.tdt.de>, \
Aaron Goodman <aaronjg@alumni.stanford.edu>
PKG_LICENSE:=GPL-2.0
diff --git a/net/mwan3/files/etc/hotplug.d/iface/16-mwan3-user b/net/mwan3/files/etc/hotplug.d/iface/16-mwan3-user
index a9f42168b..0960a2628 100644
--- a/net/mwan3/files/etc/hotplug.d/iface/16-mwan3-user
+++ b/net/mwan3/files/etc/hotplug.d/iface/16-mwan3-user
@@ -19,6 +19,7 @@
exit 0
}
+ [ -x /etc/mwan3.user ] || chmod 755 /etc/mwan3.user
env -i ACTION="$ACTION" INTERFACE="$INTERFACE" DEVICE="$DEVICE" /etc/mwan3.user
}