aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2019-02-03 09:11:03 -0500
committerGitHub <noreply@github.com>2019-02-03 09:11:03 -0500
commit03ae87406a4b8f46f8a85bc833f4b70fab4377c9 (patch)
treed6a35af13711658a8b8bb22ec1fb5aa959797484
parentfdc5c5be604cbb8b9d03da4e47a137acea46deea (diff)
parent055a81328075093488faf5dcb8fd2cd6e433e49a (diff)
Merge pull request #8113 from neheb/ava
libavahi-compat-libdnssd: Fix compilation
-rw-r--r--libs/avahi/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/libs/avahi/Makefile b/libs/avahi/Makefile
index ddacce035..df9b0f569 100644
--- a/libs/avahi/Makefile
+++ b/libs/avahi/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=avahi
PKG_VERSION:=0.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/lathiat/avahi/releases/download/v$(PKG_VERSION) \
@@ -273,8 +273,6 @@ CONFIGURE_ARGS+= \
--disable-dbm \
--enable-gdbm \
--enable-libdaemon \
- $(and $(CONFIG_PACKAGE_libavahi-compat-libdnssd),ifeq ($(BUILD_VARIANT),dbus),\
- --enable-compat-libdns_sd) \
--disable-python \
--disable-pygtk \
--disable-python-dbus \
@@ -303,6 +301,10 @@ CONFIGURE_ARGS+= \
endif
ifeq ($(BUILD_VARIANT),dbus)
+ifneq ($(CONFIG_PACKAGE_libavahi-compat-libdnssd),)
+CONFIGURE_ARGS += \
+ --enable-compat-libdns_sd
+endif
CONFIGURE_ARGS += \
--enable-dbus
else
@@ -348,7 +350,7 @@ endef
define Package/libavahi-compat-libdnssd/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdns_sd.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdns_sd.so* $(1)/usr/lib/
endef
define Package/avahi-utils/install