aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-03-20 15:04:09 -0700
committerRosen Penev <rosenp@gmail.com>2021-03-26 13:14:11 -0700
commit02d54e1a6f4f2aaee9b5f9d10124b79ff8c3f483 (patch)
treecf3a3abd4e4b8536c5a11ddc2ea79b7806102b03
parent3cfceae45fda62da91b3837f0369e76d203d6c73 (diff)
perl-mail-spamassassin: fix compilation without deprecated OpenSSL APIs
Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--lang/perl-mail-spamassassin/Makefile2
-rw-r--r--lang/perl-mail-spamassassin/patches/010-openssl-deprecated.patch28
2 files changed, 29 insertions, 1 deletions
diff --git a/lang/perl-mail-spamassassin/Makefile b/lang/perl-mail-spamassassin/Makefile
index 775ffadc8..8daa20e80 100644
--- a/lang/perl-mail-spamassassin/Makefile
+++ b/lang/perl-mail-spamassassin/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=perl-mail-spamassassin
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_VERSION:=3.4.4
PKG_HASH:=8ea27a165b81e3ce8c84ae85c3ecba1f2edfa04ef4a86f07fe28ab612fc8ff60
diff --git a/lang/perl-mail-spamassassin/patches/010-openssl-deprecated.patch b/lang/perl-mail-spamassassin/patches/010-openssl-deprecated.patch
new file mode 100644
index 000000000..819eb1536
--- /dev/null
+++ b/lang/perl-mail-spamassassin/patches/010-openssl-deprecated.patch
@@ -0,0 +1,28 @@
+--- a/spamc/libspamc.c
++++ b/spamc/libspamc.c
+@@ -1213,9 +1213,11 @@ int message_filter(struct transport *tp,
+
+ if (flags & SPAMC_USE_SSL) {
+ #ifdef SPAMC_SSL
++#if 0
+ SSLeay_add_ssl_algorithms();
+- meth = SSLv23_client_method();
+ SSL_load_error_strings();
++#endif
++ meth = SSLv23_client_method();
+ ctx = SSL_CTX_new(meth);
+ #else
+ UNUSED_VARIABLE(ssl);
+@@ -1600,9 +1602,11 @@ int message_tell(struct transport *tp, c
+
+ if (flags & SPAMC_USE_SSL) {
+ #ifdef SPAMC_SSL
++#if 0
+ SSLeay_add_ssl_algorithms();
+- meth = SSLv23_client_method();
+ SSL_load_error_strings();
++#endif
++ meth = SSLv23_client_method();
+ ctx = SSL_CTX_new(meth);
+ #else
+ UNUSED_VARIABLE(ssl);