aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-18 17:08:51 -0700
committerRosen Penev <rosenp@gmail.com>2020-04-18 18:06:33 -0700
commit0266fa2d29c107f89bb2cb7097cbe20976c4a94c (patch)
treee393457d8697e94a7e4364a39d6a3e35f5e42727
parentb836bc8c3f1c2296a3fa1189605bc4c2ca523b9e (diff)
avahi: patch client pkgconfig files without dbus
It still gets built without dbus. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/avahi/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/libs/avahi/Makefile b/libs/avahi/Makefile
index d020c1e6b..67aa0c804 100644
--- a/libs/avahi/Makefile
+++ b/libs/avahi/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=avahi
PKG_VERSION:=0.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/lathiat/avahi/releases/download/v$(PKG_VERSION) \
@@ -321,9 +321,9 @@ endif
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
$(SED) 's,/usr/lib,$$$${exec_prefix}/lib,g' $(1)/usr/lib/pkgconfig/avahi-core.pc
+ $(SED) 's,/usr/lib,$$$${exec_prefix}/lib,g' $(1)/usr/lib/pkgconfig/avahi-client.pc
ifneq ($(CONFIG_PACKAGE_libavahi-compat-libdnssd),)
ifeq ($(BUILD_VARIANT),dbus)
- $(SED) 's,/usr/lib,$$$${exec_prefix}/lib,g' $(1)/usr/lib/pkgconfig/avahi-client.pc
$(SED) 's,/usr/lib,$$$${exec_prefix}/lib,g' $(1)/usr/lib/pkgconfig/avahi-compat-libdns_sd.pc
endif
endif