aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-04-21 19:29:15 -0700
committerRosen Penev <rosenp@gmail.com>2019-04-23 16:20:36 -0700
commit01e479d56de816b31c11b129e0a225439d7bedc9 (patch)
treead5de2b625d2dc1ad3e87677fc8c19c83c7153ad
parent13914fac461e2cefcda8dc96f49fa772834b7cca (diff)
sumo: Update to 1.1.0
Cleaned up Makefile slightly. Updated URL. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--utils/sumo/Makefile24
-rw-r--r--utils/sumo/patches/100-configure_fix.patch2
2 files changed, 12 insertions, 14 deletions
diff --git a/utils/sumo/Makefile b/utils/sumo/Makefile
index 67a6eab8e..b034e2569 100644
--- a/utils/sumo/Makefile
+++ b/utils/sumo/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sumo
-PKG_VERSION:=0.27.1
+PKG_VERSION:=1.1.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/sumo
-PKG_HASH:=4494190bd6570646df7a020befe25bc66355377273d922753685737c0d38bfdf
-PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
+PKG_HASH:=68630b6879a3331683443e8044cb0a81e5919f9e4cfb80722933da85b84e542e
+PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
PKG_LICENSE:=GPL-3.0
PKG_LICENSE_FILES:=COPYING
@@ -25,20 +25,12 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
-CONFIGURE_ARGS += \
- --with-xerces=$(STAGING_DIR)/usr \
- --disable-debug \
- --disable-dependency-tracking \
- --disable-silent-rules
-
-TARGET_CXXFLAGS+=-fpermissive
-
define Package/sumo
SECTION:=utils
CATEGORY:=Utilities
TITLE:=SUMO - Simulation of Urban MObility
- URL:=http://sumo-sim.org/
- DEPENDS:=+libstdcpp +libxerces-c
+ URL:=https://sumo.dlr.de/
+ DEPENDS:=+libxerces-c
endef
define Package/sumo/description
@@ -50,6 +42,12 @@ define Package/sumo/description
various APIs to remotely control the simulation.
endef
+CONFIGURE_ARGS += \
+ --with-xerces=$(STAGING_DIR)/usr \
+ --disable-debug \
+ --disable-dependency-tracking \
+ --disable-silent-rules
+
define Package/sumo/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/{activitygen,dfrouter,duarouter,emissionsDrivingCycle,emissionsMap,jtrrouter,marouter,netconvert,netgenerate,od2trips,polyconvert,TraCITestClient} $(1)/usr/bin
diff --git a/utils/sumo/patches/100-configure_fix.patch b/utils/sumo/patches/100-configure_fix.patch
index b50048d20..e5deea5b7 100644
--- a/utils/sumo/patches/100-configure_fix.patch
+++ b/utils/sumo/patches/100-configure_fix.patch
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -117,11 +117,6 @@ dnl - - - - - - - - - - - - - - - - - -
+@@ -87,11 +87,6 @@ dnl - - - - - - - - - - - - - - - - - -
case "$host" in
x86-*-linux* | ia64-*-linux* | i586-*-linux* | i686-*-linux* | x86_64-*-linux*)
dnl Make sure we are on architecture that supports SIMD