aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-11-11 14:47:06 +0200
committerGitHub <noreply@github.com>2018-11-11 14:47:06 +0200
commit01b584c2d83f547e77ded7787ce6b5097cc18d11 (patch)
tree90342e89b35d52c4ab55091f9702a95c7ae848bd
parent734bca07090a7d4cc551c99635c5c11d9f789d9d (diff)
parent5226c0bfe92d1cb4c9108f5a54629df6ac31af82 (diff)
Merge pull request #7341 from neheb/dove
dovecot: Fix compilation for OpenSSL without deprecated APIs
-rw-r--r--mail/dovecot/Makefile2
-rw-r--r--mail/dovecot/patches/100-openssl-deprecated.patch26
2 files changed, 27 insertions, 1 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 17bccd1b2..619e906d7 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dovecot
PKG_VERSION:=2.3.2.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.dovecot.org/releases/2.3
diff --git a/mail/dovecot/patches/100-openssl-deprecated.patch b/mail/dovecot/patches/100-openssl-deprecated.patch
new file mode 100644
index 000000000..529413f63
--- /dev/null
+++ b/mail/dovecot/patches/100-openssl-deprecated.patch
@@ -0,0 +1,26 @@
+diff --git a/src/lib-dcrypt/dcrypt-openssl.c b/src/lib-dcrypt/dcrypt-openssl.c
+index c2dbd30..201ab40 100644
+--- a/src/lib-dcrypt/dcrypt-openssl.c
++++ b/src/lib-dcrypt/dcrypt-openssl.c
+@@ -20,6 +20,7 @@
+ #include <openssl/engine.h>
+ #include <openssl/hmac.h>
+ #include <openssl/objects.h>
++#include <openssl/bn.h>
+ #include "dcrypt.h"
+ #include "dcrypt-private.h"
+
+diff --git a/src/lib-ssl-iostream/iostream-openssl-context.c b/src/lib-ssl-iostream/iostream-openssl-context.c
+index e3c902e..ad6a9c1 100644
+--- a/src/lib-ssl-iostream/iostream-openssl-context.c
++++ b/src/lib-ssl-iostream/iostream-openssl-context.c
+@@ -6,6 +6,9 @@
+ #include "dovecot-openssl-common.h"
+
+ #include <openssl/crypto.h>
++#include <openssl/rsa.h>
++#include <openssl/dh.h>
++#include <openssl/bn.h>
+ #include <openssl/x509.h>
+ #include <openssl/pem.h>
+ #include <openssl/ssl.h>