aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-04-22 12:53:22 -0700
committerRosen Penev <rosenp@gmail.com>2019-04-22 13:46:25 -0700
commit016fbd0830cb98a21d2769103fa1d0520ffc818f (patch)
tree07c304499ced1f00f6bece65e995bb09d7b8c8c1
parent1246339e044e38be2d4a8274bdf420634e5b32f0 (diff)
gst1-libav: Add a hack to get it to build on mips64
octeonplus is being passed to gcc, which is incorrect and causes build failure. This works around it. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--multimedia/gst1-libav/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/multimedia/gst1-libav/Makefile b/multimedia/gst1-libav/Makefile
index b10d050ec..24cd0ac5c 100644
--- a/multimedia/gst1-libav/Makefile
+++ b/multimedia/gst1-libav/Makefile
@@ -142,8 +142,13 @@ LIBAV_CONFIGURE_DEMUXERS:=$(call FILTER_CONFIG,DEMUXER,demuxer,$(LIBAV_DEMUXERS)
LIBAV_CONFIGURE_PARSERS:=$(call FILTER_CONFIG,PARSER,parser,$(LIBAV_PARSERS))
LIBAV_CONFIGURE_PROTOCOLS:=$(call FILTER_CONFIG,PROTOCOL,protocol,$(LIBAV_PROTOCOLS))
-# Strip off FPU notation
-REAL_CPU_TYPE:=$(firstword $(subst +, ,$(CONFIG_CPU_TYPE)))
+#hack to build on mips64
+ifeq ($(CONFIG_CPU_TYPE),octeonplus)
+ REAL_CPU_TYPE:=octeon+
+else
+ # Strip off FPU notation
+ REAL_CPU_TYPE:=$(firstword $(subst +, ,$(CONFIG_CPU_TYPE)))
+endif
CONFIGURE_ARGS += \
--disable-Bsymbolic \