aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2021-02-08 04:48:22 +0800
committerJeffery To <jeffery.to@gmail.com>2021-02-08 04:49:55 +0800
commit0101070676683f6966f2b530593805fd76ed71fa (patch)
tree851631acbf1112dbd63b22935ea43b0732a85004
parentd58304047f2c443462633d580730c2aa721b70bd (diff)
python-hyperlink: Update to 21.0.0, refresh patch
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--lang/python/python-hyperlink/Makefile4
-rw-r--r--lang/python/python-hyperlink/patches/001-omit-tests.patch2
2 files changed, 3 insertions, 3 deletions
diff --git a/lang/python/python-hyperlink/Makefile b/lang/python/python-hyperlink/Makefile
index eea6aa525..4583683bf 100644
--- a/lang/python/python-hyperlink/Makefile
+++ b/lang/python/python-hyperlink/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-hyperlink
-PKG_VERSION:=20.0.1
+PKG_VERSION:=21.0.0
PKG_RELEASE:=1
PYPI_NAME:=hyperlink
-PKG_HASH:=47fcc7cd339c6cb2444463ec3277bdcfe142c8b1daf2160bdd52248deec815af
+PKG_HASH:=427af957daa58bc909471c6c40f74c5450fa123dd093fc53efd2e91d2705a56b
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
diff --git a/lang/python/python-hyperlink/patches/001-omit-tests.patch b/lang/python/python-hyperlink/patches/001-omit-tests.patch
index e0ee3bddb..5b0a7fe89 100644
--- a/lang/python/python-hyperlink/patches/001-omit-tests.patch
+++ b/lang/python/python-hyperlink/patches/001-omit-tests.patch
@@ -7,5 +7,5 @@
- packages=find_packages(where="src"),
+ packages=find_packages(where="src", exclude=["*.test", "*.test.*"]),
package_dir={"": "src"},
- package_data=dict(hyperlink=["py.typed"]),
+ package_data=dict(hyperlink=["py.typed", "idna-tables-properties.csv.gz"]),
zip_safe=False,