aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-03-05 00:10:05 -0800
committerRosen Penev <rosenp@gmail.com>2021-03-06 13:54:03 -0800
commit001422367efe227f17928a6a9f3e7be7887fd4c9 (patch)
treed85a7292ed086ccc4379511c24fe6c9ca2a463dc
parentb091d4b237fcf3c88f0904a3f35e319f7bcbef30 (diff)
meson: update to 0.56.2
This is the last version supporting Python 3.5, which is still in wide use. Going forward, python3/host would need to be used. Not sure if worth it. Remove paths section as it's deprecated. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--devel/meson/Makefile4
-rw-r--r--devel/meson/src/openwrt-cross.txt.in4
-rw-r--r--devel/meson/src/openwrt-native.txt.in2
3 files changed, 3 insertions, 7 deletions
diff --git a/devel/meson/Makefile b/devel/meson/Makefile
index 68b8093c3..b90f511af 100644
--- a/devel/meson/Makefile
+++ b/devel/meson/Makefile
@@ -1,11 +1,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=meson
-PKG_VERSION:=0.56.0
+PKG_VERSION:=0.56.2
PKG_RELEASE:=1
PYPI_NAME:=meson
-PKG_HASH:=291dd38ff1cd55fcfca8fc985181dd39be0d3e5826e5f0013bf867be40117213
+PKG_HASH:=3cb8bdb91383f7f8da642f916e4c44066a29262caa499341e2880f010edb87f4
PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
PKG_LICENSE:=Apache-2.0
diff --git a/devel/meson/src/openwrt-cross.txt.in b/devel/meson/src/openwrt-cross.txt.in
index 32e4ca48d..30b4c116c 100644
--- a/devel/meson/src/openwrt-cross.txt.in
+++ b/devel/meson/src/openwrt-cross.txt.in
@@ -11,6 +11,7 @@ c_args = [@CFLAGS@]
c_link_args = [@LDFLAGS@]
cpp_args = [@CXXFLAGS@]
cpp_link_args = [@LDFLAGS@]
+prefix = '/usr'
[host_machine]
system = 'linux'
@@ -20,6 +21,3 @@ endian = '@ENDIAN@'
[properties]
needs_exe_wrapper = true
-
-[paths]
-prefix = '/usr'
diff --git a/devel/meson/src/openwrt-native.txt.in b/devel/meson/src/openwrt-native.txt.in
index 601edfbc4..50308ec8e 100644
--- a/devel/meson/src/openwrt-native.txt.in
+++ b/devel/meson/src/openwrt-native.txt.in
@@ -8,8 +8,6 @@ c_args = [@CFLAGS@]
c_link_args = [@LDFLAGS@]
cpp_args = [@CXXFLAGS@]
cpp_link_args = [@LDFLAGS@]
-
-[paths]
prefix = '@PREFIX@'
sbindir = 'bin'
libdir = 'lib'