aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2024-02-07 14:25:14 +0100
committerToni Uhlig <matzeton@googlemail.com>2024-02-07 14:25:14 +0100
commitea968180a23d48edc121215359277e418b476487 (patch)
tree0ab12d63b9c4e305a542c96acdce52faeecb42e3 /CMakeLists.txt
parent556025b34d53c33d389de33a5c8c162e201d2267 (diff)
Read Ipv6 address and netmask using `getifaddrs()` instead of reading `/proc/net/if_inet6`.
* fixes a compatibility issue with Mac OSX Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0ff0b9b9b..6ae0dda29 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -85,9 +85,6 @@ option(ENABLE_DBUS "Build DBus notification example." OFF)
option(ENABLE_CURL "Build influxdb data write example." OFF)
option(BUILD_NDPI "Clone and build nDPI from github." OFF)
if(BUILD_NDPI)
- if(APPLE)
- message(WARNING "Building libnDPI from CMake is not supported on Apple and may fail.")
- endif()
option(BUILD_NDPI_FORCE_GIT_UPDATE "Forcefully instruments nDPI build script to update the git submodule." OFF)
unset(NDPI_NO_PKGCONFIG CACHE)
unset(STATIC_LIBNDPI_INSTALLDIR CACHE)