aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 4 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 3f5e541..532ed81 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,12 +2,13 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+DEBVERS := $(shell dpkg-parsechangelog | sed -n -e 's/^Version: //p')
%:
dh $@
+override_dh_auto_build:
+ $(MAKE) VERSION="$(DEBVERS)" all
+
override_dh_auto_install:
- echo "*** REDIRECT INITRAMFS SCRIPT" >&2
$(MAKE) DESTDIR=$(CURDIR)/debian/naskpass install
- mkdir -p $(CURDIR)/debian/naskpass/usr/share/initramfs-tools/scripts/local-top
- mv $(CURDIR)/debian/naskpass/usr/share/naskpass/naskpass.script.initramfs $(CURDIR)/debian/naskpass/usr/share/initramfs-tools/scripts/local-top/cryptroot