aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authortoni <matzeton@googlemail.com>2015-11-16 23:18:45 +0100
committertoni <matzeton@googlemail.com>2015-11-16 23:18:45 +0100
commit089551924a7c6bae2b03bee9999e5563f9267571 (patch)
tree93609cc2980068590fe21e0423fd489f55e3a236 /Makefile.am
parent5dcfb21b85391ddaace3ec7e2161859661894597 (diff)
(auto(conf|make)|dpkg) versioning fix (src/version.h shows the
DEFINITIVE version of the pkg)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1d76541..5b9f08b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,10 @@
SUBDIRS = src
+install-exec-local:
+ /bin/mkdir -p '$(prefix)/lib/cryptsetup'
+ /usr/bin/install -c src/naskpass '$(prefix)/lib/cryptsetup/naskpass'
+ rm '$(prefix)/bin/naskpass'
+ rmdir '$(prefix)/bin'
clean-local:
rm -f naskpass