aboutsummaryrefslogtreecommitdiff
path: root/net/suricata-update/Makefile
diff options
context:
space:
mode:
authorDonald Hoskins <grommish@gmail.com>2021-04-08 02:00:34 -0400
committerToni Uhlig <matzeton@googlemail.com>2022-09-11 13:21:36 +0200
commit8b7df035149b332850fc4f05786a820b0b19ae9b (patch)
tree24c3c9eb2f19042b2fd5deef149888509bbfddb7 /net/suricata-update/Makefile
parent11a010c3df7f2644388fc6a17a0649cdd6a98489 (diff)
suricata-update: Initial commit
Provide the framework for Suricata-update Signed-off-by: Donald Hoskins <grommish@gmail.com>
Diffstat (limited to 'net/suricata-update/Makefile')
-rw-r--r--net/suricata-update/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/net/suricata-update/Makefile b/net/suricata-update/Makefile
new file mode 100644
index 0000000..b7c3615
--- /dev/null
+++ b/net/suricata-update/Makefile
@@ -0,0 +1,48 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=suricata-update
+PKG_VERSION:=1.1.2
+PKG_RELEASE:=1
+PKG_LICENSE:=GPL-2.0
+
+include $(INCLUDE_DIR)/package.mk
+
+define Build/Prepare
+ true
+endef
+
+define Build/Configure
+ true
+endef
+
+define Build/Compile
+ true
+endef
+
+define Package/suricata-update
+ SUBMENU:=Firewall
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+suricata6 +python3-pip +python3-yaml
+ TITLE:=OISF Suricata IDS Update Utility
+ URL:=https://www.openinfosecfoundation.org/
+endef
+
+define Package/suricata-update/description
+ Suricata-Update provides updated ruleset lists for the Suricata IDS/IPS/NMS
+endef
+
+define Package/suricata-update/conffiles
+/etc/config/suricata-update
+endef
+
+define Package/suricata-update/install
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/etc/init.d/suricata-update $(1)/etc/init.d/suricata-update
+
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_CONF) ./files/etc/config/suricata-update $(1)/etc/config/suricata-update
+endef
+
+$(eval $(call BuildPackage,suricata-update))
+