aboutsummaryrefslogtreecommitdiff
path: root/lang/rust/Makefile
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2022-09-27 18:36:30 +0200
committerToni Uhlig <matzeton@googlemail.com>2022-09-27 19:10:26 +0200
commitbdb38febf52dafa77664f84b3d214e57b92230d7 (patch)
tree0a963d5c9d4873f50fe5c2f9a4c7f1204a90490c /lang/rust/Makefile
parent5a2fb492ae73f91f2d55c6e90694461721da8160 (diff)
rust: bump to 1.62.1
rust_host: bump to 1.62.1 Print an error and bail-out if the user forgot to adjust the feed name according to the one in feeds.conf Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'lang/rust/Makefile')
-rw-r--r--lang/rust/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 3a2cf9a..cc9403c 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -14,7 +14,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=rust
-PKG_VERSION:=1.62.0
+PKG_VERSION:=1.62.1
PKG_RELEASE:=1
PKG_LICENSE:=Apache-2.0 MIT
@@ -106,6 +106,12 @@ define Host/Install
endef
define Host/Compile
+ @echo '========================='
+ @echo '= RUSTC_TARGET_ARCH ='
+ @echo '========================='
+ @echo '$(RUSTC_TARGET_ARCH)'
+ @echo '========================='
+ $(if $(RUSTC_TARGET_ARCH),,$(error RUSTC_TARGET_ARCH is not set. Did you change the package feed name?))
cd $(HOST_BUILD_DIR) && \
CARGO_HOME='$(CARGO_HOME)' \
CXXFLAGS='$(HOST_CXXFLAGS)' \