aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2018-07-02 19:29:17 +0200
committerToni Uhlig <matzeton@googlemail.com>2022-09-11 13:28:12 +0200
commitcb70713f9ec9f234e5766eaf33cea10f2f2c6537 (patch)
treec1739986b2ab280c7faf036fd30bc2ca86075280
parent8b7df035149b332850fc4f05786a820b0b19ae9b (diff)
potd: add new package
A high scalable low to medium interactive SSH/TCP honeypot using Linux Namespaces, capabilities, seccomp, cgroups designed for OpenWrt and IoT devices. Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
-rw-r--r--net/potd/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/net/potd/Makefile b/net/potd/Makefile
new file mode 100644
index 0000000..49604fa
--- /dev/null
+++ b/net/potd/Makefile
@@ -0,0 +1,39 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=potd
+PKG_VERSION:=1.0
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/lnslbrty/potd.git
+PKG_SOURCE_VERSION:=f8497db5d14eb139820173dccba58989c4f9ca5c
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_MIRROR_HASH:=ca26c057cb3de0ddd25a5b91c3daeffcfb692e603d22c4c70c3681db0e5f7f33
+PKG_MAINTAINER:=Toni Uhlig <matzeton@googlemail.com>
+
+PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/potd
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+libseccomp +libssh @KERNEL_NAMESPACES @KERNEL_UTS_NS @KERNEL_IPC_NS \
+ @KERNEL_PID_NS @KERNEL_NET_NS @KERNEL_CGROUPS @KERNEL_CGROUP_PIDS
+ TITLE:=low to medium interactive SSH/TCP honeypot
+endef
+
+define Package/potd/description
+ A high scalable low to medium interactive SSH/TCP honeypot using Linux
+ Namespaces, capabilities, seccomp, cgroups designed for OpenWrt and IoT devices.
+endef
+
+define Package/potd/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/potd $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,potd))