aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2022-09-11 12:56:59 +0200
committerToni Uhlig <matzeton@googlemail.com>2022-09-11 13:16:27 +0200
commit97b08ad93588f32efcb72a3435e67e07a66f32ae (patch)
tree77f5501bac7aa048246256b6b5f46083c872923f
parente97019b578395703b53732f9260398513277874a (diff)
expat: add new package
Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
-rw-r--r--libs/expat/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/libs/expat/Makefile b/libs/expat/Makefile
new file mode 100644
index 0000000..e41d6fd
--- /dev/null
+++ b/libs/expat/Makefile
@@ -0,0 +1,54 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=expat
+PKG_VERSION:=2.4.7
+PKG_RELEASE:=$(AUTORELEASE)
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@SF/expat
+PKG_HASH:=9875621085300591f1e64c18fd3da3a0eeca4a74f884b9abac2758ad1bd07a7d
+
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=COPYING
+PKG_CPE_ID:=cpe:/a:libexpat:expat
+
+CMAKE_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/libexpat
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=An XML parsing library
+ URL:=https://libexpat.github.io/
+endef
+
+define Package/libexpat/description
+ A fast, non-validating, stream-oriented XML parsing library.
+endef
+
+CMAKE_OPTIONS += \
+ -DDOCBOOK_TO_MAN=OFF \
+ -DEXPAT_BUILD_TOOLS=OFF \
+ -DEXPAT_BUILD_EXAMPLES=OFF \
+ -DEXPAT_BUILD_TESTS=OFF \
+ -DEXPAT_BUILD_DOCS=OFF \
+ -DEXPAT_WITH_LIBBSD=OFF \
+ -DEXPAT_ENABLE_INSTALL=ON \
+ -DEXPAT_DTD=OFF \
+ -DEXPAT_NS=OFF \
+ -DEXPAT_DEV_URANDOM=OFF
+
+define Package/libexpat/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libexpat.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libexpat))