aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonald Hoskins <grommish@gmail.com>2021-03-27 20:48:26 -0400
committerToni Uhlig <matzeton@googlemail.com>2022-09-11 13:16:26 +0200
commit29035353ba7e200ea35bb656d5f7b4f8406d5dca (patch)
treeeb7c98b7368e91ca2efe4bda0c6852cb66097192
parent2f316dddef9b31a3e1362ad343df5424cc137187 (diff)
libhtp: Initial commit OISF LibHTP 0.5.38
LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces. Signed-off-by: Donald Hoskins <grommish@gmail.com> Co-authored-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
-rw-r--r--libs/libhtp/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/libs/libhtp/Makefile b/libs/libhtp/Makefile
new file mode 100644
index 0000000..d418547
--- /dev/null
+++ b/libs/libhtp/Makefile
@@ -0,0 +1,54 @@
+#
+# Copyright (C) 2019-2020 CZ.NIC z.s.p.o. (http://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libhtp
+PKG_VERSION:=0.5.38
+PKG_RELEASE=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/OISF/libhtp/tar.gz/$(PKG_VERSION)?
+PKG_HASH:=8365f338fdf5ef0f3b37f3cb4e2670d218c843eccc42aa87119819c0f018ef39
+
+PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
+
+PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+PKG_CPE_ID:=cpe:/a:oisf:libhtp
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libhtp
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=HTTP normalizer and parser library
+ URL:=https://github.com/OISF/libhtp
+ DEPENDS:=+zlib
+endef
+
+define Package/libhtp/description
+ LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces.
+endef
+
+CONFIGURE_ARGS += --disable-static
+
+define Build/InstallDev
+ sed -i 's|^Libs:\(.*\)*|Libs:\1 -liconv '"-L$(STAGING_DIR)/usr/lib/libiconv-full/lib"'|' $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/htp.pc
+ sed -i 's|^prefix=\(.*\)*|prefix='"$(STAGING_DIR)"'\1|' $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/htp.pc
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+define Package/libhtp/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libhtp*.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libhtp))