aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..59a6132
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Note: some files under source control may be tested with binary comparison.
+# Under git such files are protected with the `.gitattributes` file.
+# Incorrect line endings may lead to failed tests.
+if (FLATCC_TEST)
+if (FLATCC_CXX_TEST)
+ # This is tests is primarly for making sure C++ users can use
+ # generated FlatCC code. It fails for pre GCC 4.7 C++ because both
+ # stdint.h and stdalign.h are not sufficiently supported and it
+ # is not worth attempting to support in flatcc/portable.
+ add_subdirectory(monster_test_cpp)
+endif()
+add_subdirectory(cgen_test)
+add_subdirectory(monster_test)
+add_subdirectory(monster_test_solo)
+add_subdirectory(monster_test_concat)
+add_subdirectory(monster_test_prefix)
+add_subdirectory(flatc_compat)
+add_subdirectory(json_test)
+add_subdirectory(emit_test)
+add_subdirectory(load_test)
+add_subdirectory(optional_scalars_test)
+# Reflection can break during development, so it is necessary
+# to disable until new reflection code generates cleanly.
+if (FLATCC_REFLECTION)
+ add_subdirectory(reflection_test)
+endif()
+endif()