aboutsummaryrefslogtreecommitdiff
path: root/src/runtime/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/runtime/CMakeLists.txt')
-rw-r--r--src/runtime/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/runtime/CMakeLists.txt b/src/runtime/CMakeLists.txt
new file mode 100644
index 0000000..127e2a4
--- /dev/null
+++ b/src/runtime/CMakeLists.txt
@@ -0,0 +1,16 @@
+include_directories (
+ "${PROJECT_SOURCE_DIR}/include"
+)
+
+add_library(flatccrt
+ builder.c
+ emitter.c
+ refmap.c
+ verifier.c
+ json_parser.c
+ json_printer.c
+)
+
+if (FLATCC_INSTALL)
+ install(TARGETS flatccrt DESTINATION ${lib_dir})
+endif()