aboutsummaryrefslogtreecommitdiff
path: root/flatcc/src/cli/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'flatcc/src/cli/CMakeLists.txt')
-rw-r--r--flatcc/src/cli/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/flatcc/src/cli/CMakeLists.txt b/flatcc/src/cli/CMakeLists.txt
new file mode 100644
index 0000000..40facac
--- /dev/null
+++ b/flatcc/src/cli/CMakeLists.txt
@@ -0,0 +1,20 @@
+include_directories (
+ "${PROJECT_SOURCE_DIR}/include"
+ "${PROJECT_SOURCE_DIR}/config"
+)
+
+add_executable(flatcc_cli
+ flatcc_cli.c
+)
+
+target_link_libraries(flatcc_cli
+ flatcc
+)
+
+# Rename because the libflatcc library and the flatcc executable would
+# conflict if they had the same target name `flatcc`.
+set_target_properties(flatcc_cli PROPERTIES OUTPUT_NAME flatcc)
+
+if (FLATCC_INSTALL)
+ install(TARGETS flatcc_cli DESTINATION bin)
+endif()