aboutsummaryrefslogtreecommitdiff
path: root/packages/ubuntu/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'packages/ubuntu/debian/rules')
-rwxr-xr-xpackages/ubuntu/debian/rules59
1 files changed, 59 insertions, 0 deletions
diff --git a/packages/ubuntu/debian/rules b/packages/ubuntu/debian/rules
new file mode 100755
index 000000000..0000bdaf5
--- /dev/null
+++ b/packages/ubuntu/debian/rules
@@ -0,0 +1,59 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+# export DH_VERBOSE=1
+
+#
+# debian/compat
+# We should use at least comparibily version 5
+# but this requires the whole building process
+# to be remade and this is something we leave
+# to when we will have more time
+# http://www.tin.org/bin/man.cgi?section=7&topic=debhelper
+#
+
+package=ndpi
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+
+clean:
+ dh_testdir
+ dh_testroot
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ dh_installinit
+ dh_installman
+# install the files into debian/tmp.
+ cp -r ./usr/ ./debian/tmp
+ cp -r ./ndpi-dev/* ./debian/ndpi-dev/
+ -find ./debian/tmp -name .svn -exec /bin/rm -rf {} ';'
+ -find ./debian/tmp -executable -type f |xargs strip
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install