aboutsummaryrefslogtreecommitdiff
path: root/packages/ubuntu/configure
diff options
context:
space:
mode:
Diffstat (limited to 'packages/ubuntu/configure')
-rwxr-xr-xpackages/ubuntu/configure57
1 files changed, 37 insertions, 20 deletions
diff --git a/packages/ubuntu/configure b/packages/ubuntu/configure
index 857a095ca..ab2436b40 100755
--- a/packages/ubuntu/configure
+++ b/packages/ubuntu/configure
@@ -583,13 +583,12 @@ PACKAGE_URL=''
ac_subst_vars='LTLIBOBJS
LIBOBJS
-PFRING_SVN_RELEASE
-SVN_RELEASE
+GIT_COMMITS
+GIT_RELEASE
KERNEL
DATE
EXTN
MACHINE
-PFRING_VERS
NDPI_VERS
target_alias
host_alias
@@ -610,6 +609,7 @@ infodir
docdir
oldincludedir
includedir
+runstatedir
localstatedir
sharedstatedir
sysconfdir
@@ -674,6 +674,7 @@ datadir='${datarootdir}'
sysconfdir='${prefix}/etc'
sharedstatedir='${prefix}/com'
localstatedir='${prefix}/var'
+runstatedir='${localstatedir}/run'
includedir='${prefix}/include'
oldincludedir='/usr/include'
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
@@ -926,6 +927,15 @@ do
| -silent | --silent | --silen | --sile | --sil)
silent=yes ;;
+ -runstatedir | --runstatedir | --runstatedi | --runstated \
+ | --runstate | --runstat | --runsta | --runst | --runs \
+ | --run | --ru | --r)
+ ac_prev=runstatedir ;;
+ -runstatedir=* | --runstatedir=* | --runstatedi=* | --runstated=* \
+ | --runstate=* | --runstat=* | --runsta=* | --runst=* | --runs=* \
+ | --run=* | --ru=* | --r=*)
+ runstatedir=$ac_optarg ;;
+
-sbindir | --sbindir | --sbindi | --sbind | --sbin | --sbi | --sb)
ac_prev=sbindir ;;
-sbindir=* | --sbindir=* | --sbindi=* | --sbind=* | --sbin=* \
@@ -1063,7 +1073,7 @@ fi
for ac_var in exec_prefix prefix bindir sbindir libexecdir datarootdir \
datadir sysconfdir sharedstatedir localstatedir includedir \
oldincludedir docdir infodir htmldir dvidir pdfdir psdir \
- libdir localedir mandir
+ libdir localedir mandir runstatedir
do
eval ac_val=\$$ac_var
# Remove trailing slashes.
@@ -1216,6 +1226,7 @@ Fine tuning of the installation directories:
--sysconfdir=DIR read-only single-machine data [PREFIX/etc]
--sharedstatedir=DIR modifiable architecture-independent data [PREFIX/com]
--localstatedir=DIR modifiable single-machine data [PREFIX/var]
+ --runstatedir=DIR modifiable per-process data [LOCALSTATEDIR/run]
--libdir=DIR object code libraries [EPREFIX/lib]
--includedir=DIR C header files [PREFIX/include]
--oldincludedir=DIR C header files for non-gcc [/usr/include]
@@ -1670,37 +1681,43 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
-NDPI_VERS=`cat ../../config.h | grep -w VERSION | cut -d \" -f 2`
-PFRING_VERS=`cat $HOME/PF_RING/kernel/linux/pf_ring.h | grep RING_VERSION | head -1 | cut -d '"' -f 2`
-SVN_RELEASE=`svn info ../.. | grep "^Revision"|cut -d " " -f 2`
-PFRING_SVN_RELEASE=`svn info $HOME/PF_RING | grep "^Revision"|cut -d " " -f 2`
+DATE=`date -R`
+KERNEL=`uname -r`
MACHINE=`uname -m`
+SHORT_MACHINE=`uname -m | cut -b1-3`
+EXTN=""
if test $MACHINE = "x86_64"; then
- EXTN="amd64"
+ EXTN="amd64"
else
- EXTN="i386"
+ if test $SHORT_MACHINE = "aar"; then
+ EXTN="arm64"
+ else
+ if test $SHORT_MACHINE = "arm"; then
+ EXTN="armhf"
+ else
+ if test $SHORT_MACHINE = "mip"; then
+ EXTN="mips"
+ else
+ EXTN="i386"
+ fi
+ fi
+ fi
fi
-DATE=`date -R`
-KERNEL=`uname -r`
-
-
-
-
+NDPI_VERS=`cat ../../configure.ac|grep C_INIT|cut -c 21-|rev|cut -c 3-|rev`
+GIT_RELEASE=`git rev-parse HEAD`
+GIT_COMMITS=`git rev-list --all |wc -l | tr -d '[:space:]'`
+ac_config_files="$ac_config_files Makefile debian/changelog debian/files debian/control"
-ac_config_files="$ac_config_files Makefile"
-ac_config_files="$ac_config_files debian/changelog"
-ac_config_files="$ac_config_files debian/files"
-ac_config_files="$ac_config_files debian/control"
cat >confcache <<\_ACEOF