aboutsummaryrefslogtreecommitdiff
path: root/packages/openwrt/Makefile
diff options
context:
space:
mode:
authorLuca Deri <deri@ntop.org>2020-08-17 18:17:43 +0200
committerLuca Deri <deri@ntop.org>2020-08-17 18:17:43 +0200
commit673d8b7fac1f7c1f3865348190a9d48bff58f176 (patch)
treee8c586e86fda7d4e4c5be9614b16d26afd217639 /packages/openwrt/Makefile
parent1f921562d1d7962f1d23ca5b59c25f9b65073460 (diff)
Updated OpenWRT instructions
Diffstat (limited to 'packages/openwrt/Makefile')
-rw-r--r--packages/openwrt/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/packages/openwrt/Makefile b/packages/openwrt/Makefile
index ce0b410cf..5d56e18ad 100644
--- a/packages/openwrt/Makefile
+++ b/packages/openwrt/Makefile
@@ -1,22 +1,22 @@
#
-# Copyright (C) 2018 - ntop.org
+# Copyright (C) 2018-20 - ntop.org
#
include $(TOPDIR)/rules.mk
PKG_NAME:=libndpi
-PKG_VERSION:=1333.ab2f3ce
+PKG_VERSION:=17022020
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/ntop/nDPI.git
-PKG_SOURCE_VERSION:=ebf89f46e3f69d0bb8aa4c836c52ee4964431f6c
+PKG_SOURCE_VERSION:=1f921562d1d7962f1d23ca5b59c25f9b65073460
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_PROTO:=git
PKG_MAINTAINER:=Luca Deri <deri@ntop.org>
PKG_LICENSE:=GPL3
-PKG_BUILD_DEPENDS:=+libpcap
+PKG_BUILD_DEPENDS:=
PKG_BUILD_PARALLEL:=1
# autogen fix
@@ -27,7 +27,6 @@ include $(INCLUDE_DIR)/package.mk
define Package/libndpi
SECTION:=network
CATEGORY:=Network
- #DEPENDS:=+libc +libjson-c +libpthread
TITLE:=nDPI Deep Packet Inspection Library
URL:=https://www.ntop.org
endef
@@ -37,8 +36,7 @@ define Package/libndpi/description
endef
CONFIGURE_ARGS += \
- --with-pic \
- --disable-json-c \
+ --with-only-libndpi
define Build/Prepare
$(call Build/Prepare/Default)