aboutsummaryrefslogtreecommitdiff
path: root/fuzz/Makefile.am
diff options
context:
space:
mode:
authorIvan Nardi <12729895+IvanNardi@users.noreply.github.com>2023-04-06 11:30:36 +0200
committerGitHub <noreply@github.com>2023-04-06 11:30:36 +0200
commit7714507f816b36055ca25c67b6228637bd600cf9 (patch)
tree03da206586dc5748b6912a8d744e355ecebf6a3b /fuzz/Makefile.am
parent7a627296f0a032ea0d73989531f21096e1f295e9 (diff)
Test multiple `ndpiReader` configurations (#1931)
Extend internal unit tests to handle multiple configurations. As some examples, add tests about: * disabling some protocols * disabling Ookla aggressiveness Every configurations data is stored in a dedicated directory under `tests\cfgs`
Diffstat (limited to 'fuzz/Makefile.am')
-rw-r--r--fuzz/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/fuzz/Makefile.am b/fuzz/Makefile.am
index 2723b1d9c..3871faaa2 100644
--- a/fuzz/Makefile.am
+++ b/fuzz/Makefile.am
@@ -337,7 +337,7 @@ fuzz_gcrypt_light_LINK=$(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
# required for Google oss-fuzz
# see https://github.com/google/oss-fuzz/tree/master/projects/ndpi
-testpcaps := $(wildcard ../tests/pcap/*.pcap*)
+testpcaps := $(wildcard ../tests/cfgs/default/pcap/*.pcap*)
fuzz_ndpi_reader_seed_corpus.zip: $(testpcaps)
zip -j fuzz_ndpi_reader_seed_corpus.zip $(testpcaps)