aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorToni <matzeton@googlemail.com>2022-05-26 15:07:22 +0200
committerGitHub <noreply@github.com>2022-05-26 15:07:22 +0200
commit78dfe959cb175610726ae06341e55aeb39f0feba (patch)
treee0d468b515bea9ffd7d7ca5b623ff437060491c0 /Makefile.am
parent9614b66b449d84a810b0b05167c9e408bfca3d39 (diff)
Added script to compare and verify the output of `make dist'. (#1551)
This fixes some build/test issues resulting when using tarballs. * nDPI uses autotools (especially autoconf) in a wrong way, see #1163 Signed-off-by: lns <matzeton@googlemail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 86f53fff7..1b6ea524e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,18 @@ endif
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libndpi.pc
-EXTRA_DIST = README.md CHANGELOG.md CONTRIBUTING.md autogen.sh wireshark windows utils packages doc/api.rst doc/conf.py doc/flow_risks.rst doc/guide/nDPI_QuickStartGuide.pages doc/guide/nDPI_QuickStartGuide.pdf doc/img/logo.png doc/index.rst doc/Makefile doc/what_is_ndpi.rst
+EXTRA_DIST = README.md README.nDPI README.fuzzer.md CHANGELOG.md CONTRIBUTING.md \
+ autogen.sh wireshark windows utils packages \
+ influxdb/Makefile.in influxdb/metric_anomaly.c influxdb/README.txt \
+ rrdtool/Makefile.in rrdtool/README.txt rrdtool/rrd_anomaly.c rrdtool/rrd_similarity.c \
+ doc/api.rst doc/conf.py doc/flow_risks.rst doc/guide/nDPI_QuickStartGuide.pages \
+ doc/guide/nDPI_QuickStartGuide.pdf doc/img/logo.png doc/index.rst \
+ doc/Makefile doc/what_is_ndpi.rst \
+ python/DEV_GUIDE.md python/dev_requirements.txt python/ndpi_example.py python/ndpi/__init__.py \
+ python/ndpi/ndpi_build.py python/ndpi/ndpi.py python/README.md \
+ python/requirements.txt python/setup.py python/tests.py \
+ sonar-project.properties .github .lgtm/cpp-queries/packet-payload-integer-arithmetic.ql lgtm.yml
+
changelog:
git log --since={`curl -s https://github.com/ntop/ndpi/releases | grep datetime | head -n1 | egrep -o "[0-9]+\-[0-9]+\-[0-9]+"`} --name-only --pretty=format:" - %s" | grep "^ " > CHANGELOG.latest