aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorToni <matzeton@googlemail.com>2023-07-07 17:40:50 +0200
committerGitHub <noreply@github.com>2023-07-07 17:40:50 +0200
commit72814bed338f762dc29b94064c1ecffd2cb3f228 (patch)
tree18161d48f3178d9a305ef8a5438fa214f883c0f1 /Makefile.am
parentbdd295bc2c8ec51357b4b43db17b50844acce540 (diff)
Added coverage targets to `Makefile.am` for convenience. (#2039)
Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ae03af564..ff403a533 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,13 +20,23 @@ EXTRA_DIST = README.md README.fuzzer.md CHANGELOG.md CONTRIBUTING.md \
python/requirements.txt python/setup.py python/tests.py \
sonar-project.properties .github .ci-ignore
-
-.PHONY: doc doc-view
doc:
make -C doc html
doc-view:
python3 -m http.server --bind 127.0.0.1 --directory doc/_build/html 8080
+coverage: all
+ mkdir -vp coverage_report/ndpi_coverage_report
+ lcov --directory . --capture --output-file lcov.info
+ genhtml -o coverage_report/ndpi_coverage_report lcov.info
+
+clean-coverage:
+ rm -f lcov.info
+ find . -type f -name "*.gcda" -exec rm "{}" +
+ find . -type f -name "*.gcno" -exec rm "{}" +
+
changelog:
git log --since={`curl -s https://github.com/ntop/ndpi/releases | grep datetime | head -n1 | egrep -o "[0-9]+\-[0-9]+\-[0-9]+"`} --name-only --pretty=format:" - %s" | grep "^ " > CHANGELOG.latest
+
+.PHONY: doc doc-view coverage clean-coverage changelog