aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLuca Deri <deri@ntop.org>2020-10-19 15:39:48 +0200
committerLuca Deri <deri@ntop.org>2020-10-19 15:39:48 +0200
commit02de8e10ca010d56c27fe2d655fa605e1d53f414 (patch)
tree8672fcc3210f65d0f31b44973b7cf5e39eaa7b76 /Makefile.am
parentc2d8955c183259c42c1241dca2c6cf8f9c48bf9f (diff)
Added makefile target for creating changelog
Updated Changelog
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d59ad6819..1e86ebf33 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,3 +9,6 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libndpi.pc
EXTRA_DIST = README.md CHANGELOG.md CONTRIBUTING.md README.protocols autogen.sh configure.seed wireshark python windows utils packages doc/nDPI_QuickStartGuide.pages doc/nDPI_QuickStartGuide.pdf example/MacOS example/Win32
+
+changelog:
+ git log --since={`curl -s https://github.com/ntop/ndpi/releases | grep datetime | head -n1 | egrep -o "[0-9]+\-[0-9]+\-[0-9]+"`} --name-only --pretty=format:" - %s" | grep "^ " > Changelog.latest