aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorToni <matzeton@googlemail.com>2022-05-30 19:48:05 +0200
committerGitHub <noreply@github.com>2022-05-30 19:48:05 +0200
commit00ee364a7e0a0cdbf5d5323889f6e2fd9a84cd61 (patch)
tree6b57e865c53eeec3b5e4f1e96eebabc373490b29 /Makefile.am
parentca115774c9d735dc48a241682efded272011c009 (diff)
Updated README.md (#1562)
* make check great again (not so much) * make doc/doc-view * CI updates Signed-off-by: lns <matzeton@googlemail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fe9ccc27c..463c043c3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,5 +21,12 @@ EXTRA_DIST = README.md README.nDPI README.fuzzer.md CHANGELOG.md CONTRIBUTING.md
sonar-project.properties .github .ci-ignore .lgtm/cpp-queries/packet-payload-integer-arithmetic.ql lgtm.yml
+.PHONY: doc doc-view
+doc:
+ make -C doc html
+
+doc-view:
+ python3 -m http.server --bind 127.0.0.1 --directory doc/_build/html 8080
+
changelog:
git log --since={`curl -s https://github.com/ntop/ndpi/releases | grep datetime | head -n1 | egrep -o "[0-9]+\-[0-9]+\-[0-9]+"`} --name-only --pretty=format:" - %s" | grep "^ " > CHANGELOG.latest