aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authortoni <toni@pdp7.tq-net.de>2017-11-16 15:07:12 +0100
committerToni Uhlig <Toni.Uhlig@tq-group.com>2017-11-27 15:36:43 +0100
commitef0f08a3d4d8eeb118592bc96480109d7b78e37b (patch)
tree8e57959487f08dd743b2728ab6fc0269b17cf4bd /src/Makefile.am
parent91f979252aa3ce910b2a7a577f807a941b24a555 (diff)
initial commit
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..b5b9b8e
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,17 @@
+bin_PROGRAMS = utool
+
+utool_CXXFLAGS = -std=c++11 -ffunction-sections -fdata-sections -Wl,--gc-sections $(UT_CFLAGS) $(WX_CFLAGS) -DCSV_IO_NO_THREAD=1
+if UT_BUILDGUI
+utool_CXXFLAGS += -DUSE_GUI=1
+endif
+utool_LDADD = $(UT_LIBS) $(WX_LIBS)
+
+utool_SOURCES = \
+ Json.cpp \
+ UpdateFactory.cpp \
+ UpdateTool.cpp
+if UT_BUILDGUI
+utool_SOURCES += \
+ UpdateGUI.cpp \
+ JobQueue.cpp
+endif