aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authortoni <toni@pdp7.tq-net.de>2017-11-16 15:07:12 +0100
committerToni Uhlig <Toni.Uhlig@tq-group.com>2017-11-27 15:36:43 +0100
commitef0f08a3d4d8eeb118592bc96480109d7b78e37b (patch)
tree8e57959487f08dd743b2728ab6fc0269b17cf4bd /configure.ac
parent91f979252aa3ce910b2a7a577f807a941b24a555 (diff)
initial commit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac137
1 files changed, 137 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..66f9aa3
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,137 @@
+AC_PREREQ(2.58)
+AC_INIT([UpdateTool], [1.0.0], [], [], [https://dl-website.tld/utool.exe])
+AC_CONFIG_SRCDIR([src/config.h.in])
+AC_CONFIG_FILES([Makefile src/Makefile])
+
+AC_CANONICAL_BUILD
+AC_CANONICAL_HOST
+if test x"$cross_compiling" != x"no"; then
+ HOST_PREFIX="${host_alias}-"
+ HOST_SUFFIX="-$host_alias"
+ if test x"${build_alias}" = x; then
+ AC_MSG_ERROR([Cross compile enabled but no --build *explicitly* specified. For example: --build=$(gcc -dumpmachine)])
+ fi
+else
+ HOST_PREFIX=
+ HOST_SUFFIX=
+fi
+
+AM_SILENT_RULES([yes])
+AM_INIT_AUTOMAKE
+AC_PROG_CXX
+AC_PROG_INSTALL
+AC_C_CONST
+AC_C_INLINE
+AC_TYPE_SIZE_T
+AC_CHECK_HEADER_STDBOOL
+AC_FUNC_VPRINTF
+AC_FUNC_STAT
+AC_CHECK_FUNCS([malloc calloc realloc free memcmp memchr memcpy memmove memset putc putwc raise rand signal sprintf strchr strcmp strcoll strcpy strerror strftime strlen strncmp strncpy strpbrk strspn strstr strtol strtoul tolower toupper towlower towupper ungetc ungetwc vfprintf wcschr wcscmp wcscoll wcscpy wcspbrk wcsspn wcsstr wcstol wcstoul fopen fgets fprintf fputs fread fwrite getc fputc isalnum isalpha isupper time mktime gmtime close fclose feof exit],,
+ [AC_MSG_ERROR([Missing essential std functions.])])
+
+utool_major_version_number=1
+utool_minor_version_number=0
+utool_release_number=0
+UTOOL_RELEASE=${utool_major_version_number}.${utool_minor_version_number}
+UTOOL_VERSION=${UTOOL_RELEASE}.${utool_release_number}
+
+AC_ARG_ENABLE([gui],
+ [AS_HELP_STRING([--enable-gui], [Build the UpdateTool with a wxWidgets based GUI instead of a simple CLI (default enabled).])],,
+ [ut_buildgui=yes])
+ut_buildgui=$(echo ${ut_buildgui})
+case ${ut_buildgui} in
+ ''|1|y|yes) ut_buildgui=yes ;;
+ no) ut_buildgui= ;;
+ *) AC_MSG_ERROR([unknown option '${ut_buildgui}' for --enable-gui]) ;;
+esac
+
+AC_ARG_ENABLE([host-wxwidgets],
+ [AS_HELP_STRING([--enable-host-wxwidgets], [Use the system wxWidgets library instead of our own shipped in ./wxWidgets (not recommended).])],,
+ [enable_host_wxwidgets=no])
+enable_host_wxwidgets=$(echo ${enable_host_wxwidgets})
+case ${enable_host_wxwidgets} in
+ ''|1|y|yes) enable_host_wxwidgets=yes ;;
+ no) enable_host_wxwidgets= ;;
+ *) AC_MSG_ERROR([unknown option '${enable_host_wxwidgets}' for --enable-host-wxwidgets]) ;;
+esac
+if test x"${ut_buildgui}" != x"yes"; then
+ enable_host_wxwidgets=
+fi
+AC_MSG_CHECKING([for host wxWidgets])
+if test x"${enable_host_wxwidgets}" != x; then
+ AC_MSG_RESULT([${enable_host_wxwidgets}])
+else
+ AC_MSG_RESULT([disabled])
+fi
+
+if test x"${enable_host_wxwidgets}" != x"yes"; then
+ if test "${cross_compiling}" != "no"; then
+ utool_wxdir="wxWidgets-${host_alias}/"
+ else
+ utool_wxdir="wxWidgets-host/"
+ fi
+ AC_MSG_CHECKING([for wxWidgets])
+ if ! test -d "${utool_wxdir}lib"; then
+ AC_MSG_ERROR([Missing wxWidgets builddir ${utool_wxdir}: Please run \`./build_wxwidgets.sh ${host_alias:-host}\` first.])
+ fi
+ AC_MSG_RESULT([yes])
+else
+ utool_wxdir=""
+fi
+
+ut_cflags=""
+ut_libs=""
+PROGRAM_EXT=
+case "${host}" in
+ *-*-cygwin* | *-*-mingw32* )
+ PROGRAM_EXT=".exe"
+ ut_use_msw=yes
+ ut_cflags="${ut_cflags} -D_UNICODE=1 -municode"
+ ut_libs="${ut_libs} -static -lws2_32 -dynamic"
+ ;;
+esac
+
+if test x"${ut_buildgui}" = x"yes"; then
+ if test x"${ut_use_msw}" = x"yes" -a x"${enable_host_wxwidgets}" = x"yes"; then
+ AC_MSG_ERROR([Building UpdateTool for Windows based platforms is not supported with --enable-host-wxwidgets])
+ fi
+ AC_MSG_CHECKING([for wxWidgets version])
+ wx_version=$(${utool_wxdir}wx-config --version-full)
+ AC_MSG_RESULT([${wx_version}])
+ AC_MSG_CHECKING([for wxWidgets CFLAGS])
+ wx_cflags=$(${utool_wxdir}wx-config --cflags)
+ AC_MSG_RESULT([yes])
+ AC_MSG_CHECKING([for wxWidgets LIBS])
+ wx_libs=$(${utool_wxdir}wx-config --libs std)
+ AC_MSG_RESULT([yes])
+fi
+
+ut_cflags="${ut_cflags} -Wall -Wno-deprecated-declarations"
+if `echo $CXXFLAGS $CFLAGS | grep " -O" >/dev/null`; then
+ AC_MSG_WARN([CXXFLAGS/CFLAGS already contains -O flag; ignoring -Os])
+else
+ ut_cflags="${ut_cflags} -Os"
+fi
+
+AM_CONDITIONAL([UT_BUILDGUI], [test x"${ut_buildgui}" = xyes])
+AC_SUBST([UT_CFLAGS], [${ut_cflags}])
+AC_SUBST([UT_LIBS], [${ut_libs}])
+AC_SUBST([WX_CFLAGS], [${wx_cflags}])
+AC_SUBST([WX_LIBS], [${wx_libs}])
+
+AC_CONFIG_HEADERS([src/config.h:src/config.h.in])
+AC_OUTPUT
+
+cat << EOF
+
+UpdateTool was configured with:
+
+ CFLAGS/CXXFLAGS..........: ${ut_cflags}
+ Build GUI................: ${ut_buildgui:-disabled}
+ Build for Windows........: ${ut_use_msw:-disabled}
+ Host wxWidgets...........: ${enable_host_wxwidgets:-disabled}
+ wxWidgets Version........: ${wx_version:-unknown}
+ wxWidgets CFLAGS/CXXFLAGS: ${wx_cflags}
+ wxWidgets LDFLAGS........: ${wx_libs}
+
+EOF