aboutsummaryrefslogtreecommitdiff
path: root/md2html/CMakeLists.txt
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2021-10-01 14:21:33 +0200
committerToni Uhlig <matzeton@googlemail.com>2021-10-01 14:21:33 +0200
commitd071b4177c1a3897f4682e245046a45f362b6ac5 (patch)
treee8af69a24b2b97758d4e7f12a65a93185b9b5890 /md2html/CMakeLists.txt
Squashed 'deps/md4c/' content from commit 7f05330
git-subtree-dir: deps/md4c git-subtree-split: 7f0533068b4319d8cb3d0f33ca9aa66a857734a6
Diffstat (limited to 'md2html/CMakeLists.txt')
-rw-r--r--md2html/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/md2html/CMakeLists.txt b/md2html/CMakeLists.txt
new file mode 100644
index 0000000..14de671
--- /dev/null
+++ b/md2html/CMakeLists.txt
@@ -0,0 +1,22 @@
+
+set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DDEBUG")
+
+
+# Build rules for md2html command line utility
+
+include_directories("${PROJECT_SOURCE_DIR}/src")
+add_executable(md2html cmdline.c cmdline.h md2html.c)
+target_link_libraries(md2html md4c-html)
+
+
+# Install rules
+
+install(
+ TARGETS md2html
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+)
+install(FILES "md2html.1" DESTINATION "${CMAKE_INSTALL_MANDIR}/man1")
+