aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlns <matzeton@googlemail.com>2019-09-08 15:50:47 +0200
committerlns <matzeton@googlemail.com>2019-09-08 15:50:47 +0200
commitd19fb7b82d874de586a0af4984b28e32624d68ce (patch)
tree5fb4e997e1080dd59ed0bff75b266f30de64a655 /CMakeLists.txt
parent9c8fa0d4bf64138eb8a8f15a4e422d5b8081b9e3 (diff)
basic cpp web example using httplib and (j)inja
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..4967c8a
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,22 @@
+cmake_minimum_required(VERSION 2.8.9)
+project(cpp-web)
+
+set(CMAKE_CXX_FLAGS "-Wall -Wextra")
+set(CMAKE_CXX_FLAGS_DEBUG "-g")
+set(CMAKE_CXX_FLAGS_RELEASE "-O3 -fomit-frame-pointer -flto")
+
+set(CPP_HTTPLIB_SRCDIR "${PROJECT_SOURCE_DIR}/deps/cpp-httplib" CACHE STRING "Path to the cpp-httplib source directory.")
+if(NOT EXISTS "${CPP_HTTPLIB_SRCDIR}/httplib.h")
+ message(FATAL_ERROR "cpp-httplib missing")
+endif()
+
+set(INJA_SRCDIR "${PROJECT_SOURCE_DIR}/deps/inja" CACHE STRING "Path to the inja source directory.")
+if(NOT EXISTS "${INJA_SRCDIR}/single_include/inja/inja.hpp")
+ message(FATAL_ERROR "inja missing")
+endif()
+
+include_directories(${CPP_HTTPLIB_SRCDIR} ${INJA_SRCDIR}/single_include ${INJA_SRCDIR}/third_party/include)
+file(GLOB SOURCES "src/*.cpp")
+add_executable(cpp-web ${SOURCES})
+#target_compile_definitions(cpp-web PUBLIC CPPHTTPLIB_THREAD_POOL_COUNT=4)
+target_link_libraries(cpp-web pthread)