summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index da23fd8..1d161a2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,9 +18,13 @@ if HAVE_ICMPFILTER
ptunnel_ng_CFLAGS += -DHAVE_ICMPFILTER=1
endif
+if HAVE_ARC4RANDOM
+ptunnel_ng_CFLAGS += -DHAVE_ARC4RANDOM=1
+else
if HAVE_RANDOM
ptunnel_ng_CFLAGS += -DHAVE_RANDOM=1
endif
+endif
ptunnel_ng_SOURCES = \
md5.c \