aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2017-12-19 21:12:55 +0100
committerToni Uhlig <matzeton@googlemail.com>2017-12-19 21:12:55 +0100
commit00e2c4e6849adc1b9cc8b9daf9069d67ff086dc3 (patch)
tree1f9df654212d9d37e178470d99d0338fc0b4a0ad /src/Makefile.am
parent4176fdf0b64f068d123a0d960beb1eb5708f3e7b (diff)
ptunnel-ng:
* fixed missing conditionaled compile for pcap * ported to mingw64
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4e802cc..5d51807 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,12 +2,16 @@ bin_PROGRAMS = ptunnel-ng
man8_MANS = ptunnel-ng.8
ptunnel_ng_CFLAGS = -Wall
+ptunnel_ng_LDADD =
if HAVE_PCAP
ptunnel_ng_CFLAGS += -DHAVE_PCAP=1
endif
if HAVE_SELINUX
ptunnel_ng_CFLAGS += -DHAVE_SELINUX=1
endif
+if IS_WINDOWS
+ptunnel_ng_LDADD += -lws2_32
+endif
ptunnel_ng_SOURCES = \
md5.c \