aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2017-12-20 00:40:58 +0100
committerToni Uhlig <matzeton@googlemail.com>2017-12-20 00:40:58 +0100
commitdbfa491594e0c84079bebc991107e1b51a228433 (patch)
tree45c42b4abb81067f139b2acdffed18c8612577f8 /configure.ac
parent8c051422c1673e57ce70cc9dccb6e136d901cc09 (diff)
ptunnel-ng:
* fixed mingw64 cross compile issues * using getaddrinfo instead of obsolete gethostbyname * removed IS_WINDOWS AM_CONDITIONAL
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c64f45c..c89069b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,11 +42,12 @@ if test x"${use_msw}" != x"yes"; then
[AC_MSG_ERROR([Missing essential non-Windows std headers.])])
AC_SEARCH_LIBS([pthread_create], [pthread],,
[AC_MSG_ERROR([Missing pthread library.])],)
- AC_CHECK_FUNCS([pthread_mutex_init pthread_mutex_lock pthread_mutex_unlock syslog],,
- [AC_MSG_ERROR([Missing essential pthread functions.])])
+ AC_CHECK_FUNCS([pthread_mutex_init pthread_mutex_lock pthread_mutex_unlock syslog getaddrinfo freeaddrinfo gai_strerror],,
+ [AC_MSG_ERROR([Missing essential Linux std functions.])])
else
AC_CHECK_HEADERS([winsock2.h windows.h ws2tcpip.h],,
[AC_MSG_ERROR([Missing essential Windows std headers.])])
+ AC_CHECK_LIB([ws2_32],[main])
fi
AC_MSG_CHECKING([for GNU getopt_long])
@@ -145,7 +146,6 @@ fi
dnl Set automake conf vars
AM_CONDITIONAL([HAVE_PCAP], [test x"${pcap_enabled}" = xyes])
AM_CONDITIONAL([HAVE_SELINUX], [test x"${selinux_enabled}" = xyes])
-AM_CONDITIONAL([IS_WINDOWS], [test x"${use_msw}" = xyes])
dnl output config headers
AC_CONFIG_HEADERS([src/config.h:src/config.h.in])