aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2018-11-26 18:08:51 +0100
committerToni Uhlig <matzeton@googlemail.com>2018-11-26 18:09:32 +0100
commita2eee970b908ab3f898b20a546c6bc0517bd2d17 (patch)
tree58fb9082a475c22e68ab61b9f26b464cc3a32403 /configure.ac
parent3f8b7c92b4cf074345c75d72eefd5fb0ba513cc6 (diff)
fix configure error for OpenWrt also (see c1cecbab40ef2d70446308aabdef10d9c8e21be1)
Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 6585093..4d34483 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,9 +38,7 @@ dnl Check for std includes.
AC_CHECK_HEADERS([stdarg.h stdio.h unistd.h stdlib.h string.h stdint.h time.h signal.h assert.h],,
[AC_MSG_ERROR([Missing essential std headers.])])
if test x"${use_msw}" != x"yes"; then
- if test x"${use_android}" != x"yes"; then
- AC_CHECK_HEADERS([sys/unistd.h],,[AC_MSG_ERROR([Missing essential non-Windows/Android std headers.])])
- fi
+ AC_CHECK_HEADERS([sys/unistd.h],,)
AC_CHECK_HEADERS([sys/types.h sys/socket.h netinet/in.h arpa/inet.h netdb.h pthread.h errno.h net/ethernet.h syslog.h pwd.h grp.h],,
[AC_MSG_ERROR([Missing essential non-Windows std headers.])])
AC_SEARCH_LIBS([pthread_create], [pthread],,