aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2018-12-24 12:25:15 +0100
committerToni Uhlig <matzeton@googlemail.com>2018-12-24 12:25:15 +0100
commit2c7c3b62df2661b3276253fb3d8d624d81c398a2 (patch)
tree6e774153116d03025fcfce95e5ed3016af25fa96 /configure.ac
parent021b6847054cec55303efeec22a179397ce88165 (diff)
added additional autoconf ICMP_FILTER compile check
Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f45d875..0517201 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,6 +152,25 @@ if test x"${selinux_enabled}" != x; then
AC_SEARCH_LIBS([setcon], [selinux],,[selinux_enabled=],)
fi
+dnl Check for ICMP_FILTER
+AC_MSG_CHECKING([for working ICMP_FILTER])
+AC_COMPILE_IFELSE(
+[AC_LANG_PROGRAM([[
+#include <netinet/in.h>
+#include <sys/socket.h>
+#include <linux/icmp.h>
+void foo() {
+ struct icmp_filter filt;
+ int sockfd = socket(AF_INET, SOCK_RAW, IPPROTO_ICMP);
+ filt.data = ~((1<<ICMP_ECHO) | (1<<ICMP_ECHOREPLY));
+ setsockopt(sockfd, SOL_RAW, ICMP_FILTER, &filt, sizeof filt);
+}
+]], [])]
+,[AC_MSG_RESULT([yes])
+ with_icmp_filter="yes"]
+,[AC_MSG_RESULT([no])
+ with_icmp_filter="no"])
+
dnl Check for Android liblog.so
AC_SEARCH_LIBS([__android_log_vprint], [log],,,)
@@ -159,6 +178,7 @@ dnl Set automake conf vars
AM_CONDITIONAL([HAVE_PCAP], [test x"${pcap_enabled}" = xyes])
AM_CONDITIONAL([HAVE_SELINUX], [test x"${selinux_enabled}" = xyes])
AM_CONDITIONAL([IS_WINDOWS], [test x"${use_msw}" = xyes])
+AM_CONDITIONAL([HAVE_ICMPFILTER], [test x"${with_icmp_filter}" = xyes])
dnl output config headers
AC_CONFIG_HEADERS([src/config.h:src/config.h.in])