aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2018-06-05 23:33:33 +0200
committerToni Uhlig <matzeton@googlemail.com>2018-06-05 23:33:33 +0200
commit2348bccbde4409c0cb76ba299552bbfb4206f988 (patch)
tree103f79355367d3a85b00bfd88c577e28d24f49b1 /configure.ac
parentf08f519880261ec2bd72ba50bf5ff8600783fcd1 (diff)
POTD skeleton #95.
Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ea2426a..29ad884 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,6 +51,9 @@ dnl Some libssh versions require libssl,libcrypto,zlib.
dnl This is because the libssh.pc file does not sets additional required shlibs.
additional_libssh_libs=""
+CFLAGS="$CFLAGS $libssh_CFLAGS"
+LIBS="$LIBS $libssh_LIBS"
+
AC_MSG_CHECKING([if libssh requires -lcrypto])
AC_TRY_LINK([#include <libssh/libssh.h>],
[ return ssh_init(); ], [ libssh_require_libcrypto="no" ],
@@ -97,7 +100,7 @@ AC_SUBST([libseccomp_LIBS])
dnl Check for valgrind
PKG_CHECK_MODULES([valgrind], [valgrind >= 3.12.0],
[ AC_DEFINE([HAVE_VALGRIND], [1],
- [Define to 1 if you have/want valgrind support]),
+ [Define to 1 if you have/want valgrind support])
valgrind_enabled="yes" ],
[ valgrind_enabled="no" ])
AC_SUBST([valgrind_CFLAGS])