From fb86cd6dccde3fe54df2f51342d77a353a3f869b Mon Sep 17 00:00:00 2001
From: Lars-Peter Clausen <lars@metafoo.de>
Date: Mon, 11 Jan 2010 11:18:26 +0000
Subject: Add libuuid Makefile. Oops...

SVN-Revision: 19105
---
 tools/libuuid/Makefile | 50 ++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)
 create mode 100644 tools/libuuid/Makefile

(limited to 'tools')

diff --git a/tools/libuuid/Makefile b/tools/libuuid/Makefile
new file mode 100644
index 0000000000..672591fe1d
--- /dev/null
+++ b/tools/libuuid/Makefile
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=e2fsprogs
+PKG_VERSION:=1.40.11
+PKG_MD5SUM:=004cea70d724fdc7f1a952dffe4c9db8
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/e2fsprogs
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Configure
+	$(call Host/Configure/Default,\
+		--enable-shared \
+		--enable-static \
+		--disable-rpath \
+		--enable-elf-shlibs \
+		--disable-dynamic-e2fsck \
+		--disable-tls \
+		--disable-uuidd \
+		--without-libiconv-prefix \
+		--without-libintl-prefix \
+	)
+endef
+
+define Host/Compile
+	$(MAKE) -C $(HOST_BUILD_DIR)/lib/uuid
+endef
+
+define Host/Install
+	$(INSTALL_DIR) $(STAGING_DIR_HOST)/{lib,include}
+	$(CP) $(HOST_BUILD_DIR)/lib/uuid/uuid.h $(STAGING_DIR_HOST)/include/
+	$(CP) $(HOST_BUILD_DIR)/lib/uuid/libuuid.{so*,a} $(STAGING_DIR_HOST)/lib/
+endef
+
+define Host/Clean
+	rm -f $(STAGING_DIR_HOST)/include/uuid.h
+	rm -f $(STAGING_DIR_HOST)/lib/uuid/libuuid.{so*,a}
+	$(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))
-- 
cgit v1.2.3