From 03c7c8c8530cc899bf04d0559d575ba0ea1de19c Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@nbd.name>
Date: Sat, 15 Sep 2018 15:49:31 +0200
Subject: tools/e2fsprogs: fix build with clang

Signed-off-by: Felix Fietkau <nbd@nbd.name>
---
 tools/e2fsprogs/Makefile | 3 +++
 1 file changed, 3 insertions(+)

(limited to 'tools')

diff --git a/tools/e2fsprogs/Makefile b/tools/e2fsprogs/Makefile
index fec6d83454..f11ce52ca0 100644
--- a/tools/e2fsprogs/Makefile
+++ b/tools/e2fsprogs/Makefile
@@ -20,6 +20,9 @@ HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+ifneq ($(shell $(HOSTCC) --version | grep clang),)
+  HOST_CFLAGS += -D__GNUC_PREREQ\(...\)=0
+endif
 HOST_CFLAGS += $(FPIC)
 
 HOST_CONFIGURE_ARGS += \
-- 
cgit v1.2.3