From b1fa9e3d2bbbcbb1da522f23ac83d411136b74de Mon Sep 17 00:00:00 2001
From: Andre Heider <a.heider@gmail.com>
Date: Fri, 27 Jan 2023 17:53:02 +0100
Subject: tools: add mold, a modern linker

mold is a faster drop-in replacement for existing Unix linkers.

A single binary is able to link various targets, which is why this lives
in tools/.

All toolchain builds then just need to copy the linker over, hence avoiding
multiple builds with the same outcome.

Signed-off-by: Andre Heider <a.heider@gmail.com>
---
 tools/mold/Makefile | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 tools/mold/Makefile

(limited to 'tools/mold/Makefile')

diff --git a/tools/mold/Makefile b/tools/mold/Makefile
new file mode 100644
index 0000000000..e8fcecbfed
--- /dev/null
+++ b/tools/mold/Makefile
@@ -0,0 +1,22 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mold
+PKG_VERSION:=1.11.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL_FILE:=v$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/rui314/mold/archive/refs/tags
+PKG_HASH:=99318eced81b09a77e4c657011076cc8ec3d4b6867bd324b8677974545bc4d6f
+
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+CMAKE_HOST_OPTIONS += \
+	-DMOLD_LTO=ON \
+	-DMOLD_MOSTLY_STATIC=ON \
+	-DMOLD_USE_SYSTEM_MIMALLOC=OFF \
+	-DMOLD_USE_SYSTEM_TBB=OFF
+
+$(eval $(call HostBuild))
-- 
cgit v1.2.3