From 56231056ea784f1cec6450f649b1adaed1f56366 Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Thu, 6 Sep 2007 16:27:37 +0000
Subject: strip the kernel version suffix from target directories, except for
 brcm-2.4 (the -2.4 will be included in the board name here).
 CONFIG_LINUX_<ver>_<board> becomes CONFIG_TARGET_<board>, same for profiles.

SVN-Revision: 8653
---
 target/linux/rdc/patches/000-rdc_fixes.patch | 71 ++++++++++++++++++++++++++++
 1 file changed, 71 insertions(+)
 create mode 100644 target/linux/rdc/patches/000-rdc_fixes.patch

(limited to 'target/linux/rdc/patches/000-rdc_fixes.patch')

diff --git a/target/linux/rdc/patches/000-rdc_fixes.patch b/target/linux/rdc/patches/000-rdc_fixes.patch
new file mode 100644
index 0000000000..306fac79a6
--- /dev/null
+++ b/target/linux/rdc/patches/000-rdc_fixes.patch
@@ -0,0 +1,71 @@
+diff -urN linux-2.6.19/arch/i386/Kconfig linux-2.6.19.new/arch/i386/Kconfig
+--- linux-2.6.19/arch/i386/Kconfig	2006-11-29 22:57:37.000000000 +0100
++++ linux-2.6.19.new/arch/i386/Kconfig	2006-12-17 17:13:33.000000000 +0100
+@@ -180,6 +180,14 @@
+ 	  Only choose this option if you have such a system, otherwise you
+ 	  should say N here.
+ 
++config X86_RDC
++	bool "Support for RDC 3211 boards"
++	help
++	  Support for RDC 3211 systems. Say 'Y' here if the kernel is 
++	  supposed to run on an IA-32 RDC R3211 system.
++	  Only choose this option if you have such as system, otherwise you
++	  should say N here.
++
+ endchoice
+ 
+ config ACPI_SRAT
+diff -urN linux-2.6.19/arch/i386/Makefile linux-2.6.19.new/arch/i386/Makefile
+--- linux-2.6.19/arch/i386/Makefile	2006-11-29 22:57:37.000000000 +0100
++++ linux-2.6.19.new/arch/i386/Makefile	2006-12-17 17:13:33.000000000 +0100
+@@ -92,6 +92,10 @@
+ mflags-$(CONFIG_X86_ES7000)	:= -Iinclude/asm-i386/mach-es7000
+ mcore-$(CONFIG_X86_ES7000)	:= mach-default
+ core-$(CONFIG_X86_ES7000)	:= arch/i386/mach-es7000/
++# RDC subarch support
++mflags-$(CONFIG_X86_RDC)	:= -Iinclude/asm-i386/mach-rdc
++mcore-$(CONFIG_X86_RDC)		:= mach-default
++core-$(CONFIG_X86_RDC)		+= arch/i386/mach-rdc/
+ 
+ # default subarch .h files
+ mflags-y += -Iinclude/asm-i386/mach-default
+--- timex.h	2007-08-07 10:44:03.816112250 -0700
++++ linux/include/asm-i386/timex.h	2007-08-07 10:48:47.905866750 -0700
+@@ -11,6 +11,8 @@
+ 
+ #ifdef CONFIG_X86_ELAN
+ #  define CLOCK_TICK_RATE 1189200 /* AMD Elan has different frequency! */
++#elif defined(CONFIG_X86_RDC)
++#  define CLOCK_TICK_RATE 1041667 /* Underlying HZ for R8610 */
+ #else
+ #  define CLOCK_TICK_RATE 1193182 /* Underlying HZ */
+ #endif
+--- reboot_fixups.c	2007-08-07 12:02:00.908412250 -0700
++++ linux/arch/i386/kernel/reboot_fixups.c	2007-08-07 12:18:49.391438500 -0700
+@@ -13,6 +13,17 @@
+ #include <linux/pci.h>
+ #include <asm/reboot_fixups.h>
+ #include <asm/msr.h>
++
++static void r8610_reset(struct pci_dev *dev)
++{
++	int i;
++
++	outl(0x80003840,0xCF8);
++	i=inl(0xCFC);
++	i |= 0x1600;
++	outl(i,0xCFC);
++	outb(1,0x92);
++}
+ 
+ static void cs5530a_warm_reset(struct pci_dev *dev)
+ {
+@@ -40,6 +53,7 @@
+ };
+ 
+ static struct device_fixup fixups_table[] = {
++{ 0x17F3, 0x6030, r8610_reset },
+ { PCI_VENDOR_ID_CYRIX, PCI_DEVICE_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset },
+ { PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_CS5536_ISA, cs5536_warm_reset },
+ };
-- 
cgit v1.2.3